Sunteți pe pagina 1din 6

Facultatea Transporturi Specializarea Ingineria Transporturilor

Disciplina: Sisteme integrate GIS/GPS Lucrare de laborator Nr. 1

Introducere n ArcGIS
Cuprins
1. 2. 3. 4. 5. 6. 7. 8. 9. 10. 11. Prezentare general a pachetelor de programe GIS nceperea sesiunii de lucru Vizualizarea datelor n ArcCatalog Conexiunea la surse de date Instrumenetele Zoom, Pan, Identify Introducere n ArcMap Ordinea straturilor de reprezentare Simbolizarea n ArcMap Proprietile Data Frame Layout View Salvarea fiierului hart i ncheierea sesiunii de lucru

1. Prezentare general a pachetelor de programe ArcGIS


ArcGIS este un pachet de programe produs de compania ESRI care permite crearea, prelucrarea, integrarea analiza i afiarea datelor geografice la diferite niveluri. n cadrul arhitecturii ArcGIS (fig. 1) utilizatorii pot accesa clieni ArcGIS (ArcView, ArcEditor, ArcInfo) sau servere (ArcSDE, ArcGIS server and ArcIMS). ArcGIS Desktop asigura accesul la diferii clieni n cazul n care datele sunt locale.

Fig. 1. Structura de baz a arhitecturii pachetelor de programe ArcGIS

I-1

Principalele trei componente ale ArcGIS Desktop sunt: ArcView ArcEditor ArcInfo Toate aceste trei componente sunt structurate conform aceleai structuri de baz (fig. 2).

Fig. 2. Componente ArcGIS Desktop

ArcView 9.x este o component GIS care permite vizualizarea, interogarea, analiza i crearea hrilor. Ofer instrumente pentru explorare, selectare, editare, afiare, analiz, simbolizare i clasificarea datelor, precum i pentru actualizarea metadatelor. ArcEditor 9.x este o aplicaie intermediar ArcGIS, care ofer mai multe funcii dect ArcView, dar mai puine dect ArcInfo. Aa cum indic numele, ArcEditor conine n plus funcii importante pentru editarea entitilor tip coverage i geodatabase. ArcInfo 9.x este componenta cea mai complex ArcGIS n plus fa de funciile de afiare i interogare incluse de ArcView i de funciile de editare incluse de ArcEditor, ArcInfo ofer funcii de geoprocesare i conversie a datelor, necesare pentru realizarea unor soluii complete GIS. Toate aceste trei versiuni includ aplicaiile ArcCatalog, ArcMap (fiecare aplicaie incluznd propria aplicaie ArcToolbox).

2. nceperea sesiunii de lucru


Sistemul de operare utilizat este Windows XP; Contul n care se lucreaz este Student fr parol; Pentru deschiderea aplicaiei ArcCatalog: Clic Start->All Programs->ArcGIS->ArcCatalog sau Clic icoana ArcCatalog de pe desktop (dac exist).

Pentru deschiderea aplicaiei ArcCatalog: Clic Start->All Programs->ArcGIS->ArcMap sau Clic icoana ArcMap de pe desktop (dac exist).

I-2

3. Vizualizarea datelor n ArcCatalog


ArcCatalog este un instrument pentru vizualizarea structurilor de directoare i fiiere i organizarea datelor GIS. Arborele catalog din fereastra din stnga este pentru vizualizarea i organizarea structurilor de directoare i fiiere. Obiectele selectate n stnga sunt afiate n fereastra din partea dreapt. Pentru a vizualiza mai multe informaii referitoare la obiectele din arorele Catalog se utilizeaz butoanele Contents, Preview i Metadata (prezentate detaliat ulterior).

Fig. 3. Fereastra aplicaiei ArcCatalog

ArcCatalog prezint lista curent a unitilor i directoarelor de pe calculator. Aplicaia lucreaz similar Window Explorer. Clic D:\; creai un director nou cu numele grupei Grupa_82xxx; n noul director creai un alt director Lucrare_Lab1; Parcurgei structura de fiiere i poziionai-v n directorul C:\arcgis\ArcTutor\Catalog. Copiai directorul Yellowstone n directorul D:\Grupa82xxx\Lucrare_Lab1.

Atenie !!! Fiierele terse din ArcCatalog nu se mut n Recycle Bin i nu mai pot fi recuperate!

I-3

4. Conexiunea la datele surs (directorul de lucru)


ArcCatalog permite setarea cii surselor de date, permindu-se accesul rapid la directorul n care se lucreaz i la fiierele din acel director. Identificai butonul din bara de sus. Clic pe acest buton pentru a crea o conexiune pentru calea D:\Grupa82xxx\Lucrare_Lab1. Accesai conexiunea direct D:\Grupa82xxx\Lucrare_Lab1; parcurgei lista de structuri i de fiiere din directorul Yellowstone; pentru fiecare fiier selectai butoanele Content i Preview; observai tipurile fiierelor i particularitile fiecrui tip; Selectai butonul Metadata; este deschis o fereastr n care sunt afiate informaii care descriu setul de date spaiale; prin selectarea butonului Spatial sunt afiate informaii referitoare la sistemul de proiecie, sistemul de coordonate, iar prin selectarea butonului Attributes sunt afiate toate atributele asociate clasei de obiecte selectate; n arborele ArcCatalog selectai D:\Grupa82xxx\Lucrare_Lab1\Yellowstone\states\polygon; Selectai butonul Preview i din lista dropdown Preview din partea de jos a paginii alegei Preview - Table. Este afiat coninutul tabelei aociate setului de date states polygon. Numrul total de nregistrri este afiat n partea de jos a ferestrei. Prin selectarea unui camp din tabele i apoi clic-dreapta se pot selecta proceduri pentru sortarea valorilor nregistrate, efectuarea unei statistici simple sau setarea proprietilor cmpului respective (Freeze/Unfreeze). 1a) Care sunt tipurile de clase de obiecte stocate n ..\Yellowstone\vegetation? 1b) Ce sistem de proiecie s-a utilizat n ..\Yellowstone\vegetation? 2a) Cte nregistrri sunt n \Yellowstone\yellowstone.mdb\water\lakes? 2b) Care este lacul cu cea mai mare arie? (indicaie utilizai procedura Sort Descending)

5. Instrumente Zoom, Pan i Identity


ArcCatalog permite parcurgerea datelor geografice, pentru identificarea informaiilor detaliate selectate din atributele tabelelor i crearea thumbnails pe datele geografice. Identificai n aplicaia ArcCatalog meniul

Dac nu l-ai gsit, l putei activa din meniul View->Toolbars->Geography. Primele dou instrumente pot mri sau micora imaginea. Al treilea instrument, Pan, poate fi utilizat pentru deplasarea datelor afiate. Butonul ( i ) poate fi utilizat pentru interogarea datelor. Ultimul buton creaz thumbnails pe datele geografice, adic creaz o imagine mic a datelor geografice care este afiat n meniul Content. Selectai n arborele ArcCatalog D:\Grupa82xxx\Lucrare_Lab1\Yellowstone\yellowstone.mdb\roads; Clic pe butonul Preview -Geography. Exersai utilizarea butoanelor Zoom in, Zoom out, Pan, Identify i Thumbnails pe clasa de obiecte roads.

I-4

6. Introducere n ArcMap
ArcMap este aplicaia principal pentru: Explorarea datelor surs (geografice i non-geografice) Analiza datelor; Afiarea rezultatelor; Personalizarea interfeei; Prezentarea rezultatelor.

Pentru deschiderea aplicaiei ArcMap: Clic Start -> All Programs -> ArcGIS -> ArcMap sau n ArcCatalog de la butonul Launch ArcMap .

n ArcCatalog selectai C:\arcgis\ArcTutor\ArcReader and Publisher i mutai Gulf of St. Lawrence.mxd n ArcMap. n ArcMap este deschis un document hart, cu mai multe straturi. Lista straturilor tematice este afiat n fereastra din stnga, datele geografice sunt afiate n dreapta.

Caracteristici ArcMap: ArcMap include bara de instrument Zoom in, Zoom out, Pan, Select Elements i Identify, similare cu cele din ArcCatalog. ArcMap are dou opiuni de afiare: Data View i Layout View (n partea de jos a ferestrei din dreapta). Data View este pentru vizualizare, interogare i manipularea datelor, n timp ce Layout View este pentru prelucrarea pentru tiparire. ArcMap organizeaz seturile de date n Data frames. Fiecare data frame conine seturi de date shape files, grids, coverages sau geodatabase. Pentru asigurarea legturii ntre aceste baze de date seturile de date trebuie s fie definite n acelai system de coordonate. Dac unul din seturile de date nu are sistem de coordinate definit, atunci apare un mesaj de avertizare i este utilizat sistemul de coordonate al primului set ncrcat. n ArcMap se lucreaz cu documente hart, cu extensia *.mxd. Orice set de date adugat va fi salvat n fiierul cu extensia mxd. Un set de date geografice reprezint n ArcGIS Desktop un "layer" GIS. Un layer include un set de date particulare, incluse ntr-un singur model spaial (poate conine un singur tip de date, de exemplu tip punct). n ArcGIS Desktop exist dou tipuri principale de reprezentare a datelor: Feature data date vectoriale; Image Data date raster.

Layer-ele pot fi adugate i terse dintr-o hart, fr sa fie afectate datele din layer-ul respectiv. tergerea unui layer din ArcMap nu nsemn tergerea fiierului layer de pe hard disc.

I-5

7. Ordinea layer-elor
Fereastra Table of Contents din ArcMap conine lista layer-elor n ordinea n care ele au fost adugate i n ordinea n care ele sunt afiate. Clic check box a layer-ului Major roads. Observai ce se ntmpl. Schimbai ordinea layer-elor (prin selectare cu butonul stnga, tragere i eliberare cnd apare bara neagr) Rearanjai layer-ele n ordinea Cities, Major roads i Base Map.

8. Simbolizarea n ArcMap Symbolization in ArcMap


ArcMap permite atribuirea unui mod de reprezentare pentru fiecare layer. Modificai modul de reprezentare al layer-elor prin selectarea simbolului afiat lng numele layer-ului. Se va deschide o fereastr n care se poate selecta tipul de simbol, culoarea, dimensiunea etc.

9. Proprietile Data Frame


Layerele sunt organizate n data frame-uri. Un date frame conine seturi de date care se refer la un proiect, la o arie sau la un anumit subiect. La deschiderea ArcMap este creat implicit un data frame numit Layers (layer implicit/default). Numele Data frame poate fi schimbat: Clic de dou ori pe nume i modificat sau Clic dreapta pe nume, selectat opiunea Properties- butonul General i modificat numele n Name box.

10. Layout View


Layout view permite proiectarea hrii pentru tiprire i adugarea informaiilor suplimentare (titlu, scar, legend, alte comentarii etc). Clic butonul glob (full extent) pentru a adduce toate layer-ele n ferestra de afiare; Select View->Layout View din meniul de sus sau butonul pagina din partea de jos a fereastrei din dreapta; Setai opiunile de pagin/tiprire din FILE->PAGE SETUP : A4 size (8.5 x 11), Landscape; Din meniul Insert selectai opiunile Title, Legend, North Arrow, Scale Bar pentru introducerea titlului, legendei etc.

3)Care sunt caracteristicile modurilor de lucru Data View i Layout view? Cnd se lucreaz n Data View i cnd n Layout View ? 4) Ce este un Data Frame?

12. Salvarea fiierului hart


Selectai FILE->SAVE AS i salvai fiierul hart n directorul D:\Grupa82xxx\Lucrare_Lab1\ cu numele lab1.mxd ; Click File->Exit din ArcCatalog i ArcMap.

I-6