Sunteți pe pagina 1din 13

is a CISCO Networking Academy

is a CISCO Networking Academy

Sedinta 4 :

1. INTERVLAN ROUTING cu MULTILAYER SWITCH

2. CONFIGURARE
is a CISCO Networking Academy

MULTILAYER SWITCH (MLS)

• Un Multi-Layer Switch poate procesa


• PDU de Layer 2 (frame-uri ETHERNET)
• PDU de Layer 3 (pachete IPv4)

• Traficul intre Vlan-uri este rutat in MLS fara a mai utiliza un Router

• Se poate realiza prin


1. Interfete SVI = Switched Virtual Interface
• O interfata SVI este activa atunci cand exista cel putin o interfata
fizica din acelasi VLAN cu cel din SVI (exemplu:
• Interfata VLAN40 – trebuie sa exista o interfata de tip access in
VLAN-ul 40 => interfata SVI va fi in starea UP. (sau)
• Interfata VLAN50 – trebuie sa existe o interfata de tip trunk care sa
aiba permis VLAN-ul 50 => interfata SVI va fi UP

2. ROUTED Ports = Interfete pe care se poate configura o adresa IPv4


is a CISCO Networking Academy

MULTILAYER SWITCH (MLS)


is a CISCO Networking Academy

MULTILAYER SWITCH (MLS)

• Interfata SVI:
• Este asociata unui VLAN
• Functioneaza ca o interfata de Router: proceseaza informatia la
nivel de pachet IP (dupa IP destinatie) pentru toate porturile
asociate din VLAN-ul respectiv
• Adresa IP a SVI-ului este considerata Default-gateway pentru
host-urile din VLAN-ul respectiv
• Implicit este creata pe Switch doar interfata SVI a VLAN-ului cu
ID=1 (SVI=1 este interfata de management pentru Switch)

• Metoda de rutare inter-vlan cu SVI este solutia OPTIMA:


• Este scalabila (orice VLAN poate avea un SVI)
• Este performanta(traficul este rutat in Switch – in Hardware
ci nu in Software)
is a CISCO Networking Academy

MULTILAYER SWITCH (MLS)

• Routed ports:
• Se intalnesc intre nivelele Distribution si Core
• Un port routed este un port fizic al MLS dar configurat sa ia
decizii in functie de PDU de Layer 3 (IP destinatie)
• Aceste porturi NU sunt asociate vreunui VLAN (isi pierd
caracteristicile de Layer 2)
• Un port se poate transforma din L2 in L3 cu comanda:
Switch(config)#interface f0/5
Switch(config-if)#no switchport
is a CISCO Networking Academy

MULTILAYER SWITCH (MLS)

• Routed ports:
is a CISCO Networking Academy

Configurare Multilayer Switch cu interfete SVI

Interfata SVI pentru VLAN10 Interfata SVI pentru VLAN20


is a CISCO Networking Academy

Configurare Multilayer Switch cu interfete SVI

Pasul 1: Activam functiile de Layer 3


Switch(config)#ip routing

Pasul 2: Asociem porturile access cu VLAN-urile corespunzatoare


S1(config)#interface f0/11
S1(config-if)#switchport access vlan 10
S1(config-if)#exit

S1(config)#interface f0/6
S1(config-if)#switchport access vlan 20
S1(config-if)#exit

Pasul 3: Cream interfetele SVI si le alocam adrese IP statice


S1(config)#interface vlan 10
S1(config-if)#ip address 10.10.1.1 255.255.255.0
S1(config-if)#no shutdown
S1(config-if)#exit
is a CISCO Networking Academy

Configurare Multilayer Switch cu interfete SVI

S1(config)#interface vlan 20
S1(config-if)#ip address 10.20.1.1 255.255.255.0
S1(config-if)#no shutdown
S1(config-if)#exit

Pasul 4: Alocam IP-uri pe calculatoare


PC1: PC3:
IP: 10.10.1.2 IP: 10.20.1.2
MASCA: 255.255.255.0 MASCA: 255.255.255.0
DG: 10.10.1.1 DG: 10.20.1.2
is a CISCO Networking Academy

Configurare Multilayer Switch cu porturi Routed

Pasul 1: Activam functiile de Layer 3


Switch(config)#ip routing

Pasul 2: Transformare interfete in routed ports


Switch(config)#interface f0/1
Switch(config-if)#ip address 10.10.1.1 255.255.255.0
% IP addresses may not be configured on L2 links
Switch(config-if)#no switchport
Switch(config-if)#ip address 10.10.1.1 255.255.255.0
Switch(config-if)#exit

Switch(config)#interface f0/2
Switch(config-if)#no switchport
Switch(config-if)#ip address 10.20.1.1 255.255.255.0
Switch(config-if)#exit

Mesajul cu rosu indica faptul ca interfata functioneaza la Layer2


Modul default in care interfata functioneaza (L2 sau L3) difera in functie de platforma
(exemple: la 3560 porturile sunt L2, la 6500 sunt L3)
is a CISCO Networking Academy

Configurare Multilayer Switch cu porturi Routed

Pasul 3: Alocam IP-uri pe host-uri similar cu metodele anterioare


PC1: PC3:
IP: 10.10.1.2 IP: 10.20.1.2
MASCA: 255.255.255.0 MASCA: 255.255.255.0
DG: 10.10.1.1 DG: 10.20.1.1
is a CISCO Networking Academy

Verificare:

Switch#show ip interface [interface_type_port |svi_number]

Switch#show interface [interface_type_port |svi_number]

Switch#show running interface [type_port |svi_number]

Switch#show ip route

Switch#show vlan

Switch#show interface trunk