Sunteți pe pagina 1din 5

Nume şi prenume:.................................... Data:...............

Clasa:.......................
TEST
Timp de lucru 20 minute.

1. Completaţi spaţiul liber din enunţul de mai jos:


Algoritmul este............................................................ a unor clase de probleme descrisă
pas cu pas.
2. Asociaţi câte un element din coloana 1 cu un element din coloana 2, astfel încât să
rezulte un algoritm de pregătire a unei prăjituri:
Pas 1 Se caută reţeta
Pas 2 Se citeştereţeta
Pas 3 Se pregătesc ingredientele
Pas 4 Se combină ingredientele conform reţetei
Pas5 Se pregăteşte tava
Pas 6 Se toarnă prăjitura în tavă
Pas 7 Se porneşte cuptorul
Pas 8 Se bagă tava la cuptor
Pas 9 Se verifică dacă este coaptă prăjitura
Pas 10 Când este gata se scoate din cuptor şi se serveşte prăjitura
3. Descrieţi un algoritm pentru pregătirea temelor la matematică pentru a doua zi de
şcoală.

4. Enumeraţi două activităţi zilnice pentru care pot fi creaţi algoritmi.

5. Care dintre următorii algoritmi este un algoritm corect pentru adunarea a 3 numere
întregi?
a) Pas 1: Citim numerele în variabilele a, b şi c
Pas 2: S=a+b+c
Pas 3: Afişăm valoarea lui S

b) Pas 1: Citim numerele în variabilele S, b şi c


Pas 2: S=a+b+c
Pas 3: Afişăm valoarea lui a

Barem de corectare test

Nr. întrebare Răspunsul corect Punctaj


Oficiu 1
1 O metodă de rezolvare 1
2 Răspuns corect 2 (1 / 5 asocieri corecte)
3 Algoritm corect 2
4 Două activităţi bine alese 2 (1 /activitate)
5 a) 2
Total 10
Nume şi prenume:.................................... Data:...............
Clasa:.......................
TEST
1. Se consideră algoritmul alăturat, descris în pseudocod.
S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y.
citeşte x (număr întreg)
┌dacă x<0 atunci
│ x ← -x
└■
p←1
┌pentru i←1,x execută
│ p ← (p*4)%10
└■
scrie p
Scrieţi ce se va afişa pentru x=8.
a) 6 b) 0 c) 4 d) 1
2. Se consideră algoritmul alăturat, descris în pseudocod.
S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y.
citeşte x (număr natural nenul)
nr ←0
┌pentru i←1,x execută
│ citeşte n (număr întreg)
│┌dacă n%x=0 atunci
││ nr←nr+1
│└■
└■
scrie nr
Bifaţi valoarea afişată în urma executării algoritmului dacă se citesc, în ordine, valorile: 5, 14,
6, 15, 16, 90.
a) 1 b) 5 c) 0 d) 2
3. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu x%y restul împărţirii
numărului natural x la numărul natural nenul y.
citeşte x (număr natural nenul)
nr ←0
┌pentru i←1,x execută
│ citeşte n (număr întreg)
│┌dacă n%x=0 atunci
││ nr←nr+1
│└■
└■
scrie nr
Ştiind că valoarea citită pentru x este 7, scrieţi un şir de numere distincte care pot fi citite în
continuare astfel încât valoarea afişată să fie 0.
a) 24 18 13 36 51 76 73 c) 56 34 57 23 65 14 77
b) 112 7 28 56 77 21 49 d) 33 23 45 65 34 23 12
4. Se consideră algoritmul alăturat, descris în pseudocod.
S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y.
citeşte x (număr întreg)
┌dacă x<0 atunci
│ x ← -x
└■
p←1
┌pentru i←1,x execută
│ p ← (p*4)%10
└■
scrie p
Bifaţi toate numerele naturale, de câte o singură cifră,care, citite pentru x, determină afişarea
valorii 4.
a) 1 (CORECT!) c) 7 (CORECT!) e) 4
b) 9 (CORECT!) d) 3 (CORECT!) f) 5 (CORECT!)
5. Se consideră algoritmul alăturat, descris în pseudocod.
S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y, iar cu [z]
partea întreagă a numărului real z.
citeşte n, k (numere naturale nenule)
┌pentru i←1,n execută
│ ┌dacă [i/k]=0 atunci
│ │ scrie i
│ │ k←k-1
│ │altfel
│ │ scrie i%k
│ └■
└■
Dacă n=11, bifaţi cea mai mică valoare care poate fi citită pentru k astfel încât, în urma
executării algoritmului, să se afişeze, în ordine, toate numerele naturale din intervalul închis
[1,11].
a) 1 b) 22 c) 11 d) 10
6. Se consideră algoritmul alăturat, descris în pseudocod.
S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y, iar cu [z]
partea întreagă a numărului real z.
citeşte n, k (numere naturale nenule)
┌pentru i←1,n execută
│ ┌dacă [i/k]=0 atunci
│ │ scrie i
│ │ k←k-1
│ │altfel
│ │ scrie i%k
│ └■
└■
Scrieţi valorile care se vor afişa dacă se citesc, în ordine, numerele 7 şi 5.
a) 1234012 b) 1201201 c) 1234567 d) 1212121
Barem de corectare test

Nr. întrebare Răspunsul corect Punctaj


Oficiu 1
1 a) 1
2 d) 1
3 a) si d) 2
4 a) b) c) d) f) 3
5 b) 1
6 b) 1
Total 10