Sunteți pe pagina 1din 2

1. n programul pseudocod alturat se consider c valoarea citit pentru variabila n este un numr natural de cel mult 9 cifre.

a) Ce se va afia pentru n=261305? b) Enunai proprietatea pe care trebuie s o aib valoarea lui n pentru ca valoarea afiat s reprezinte chiar numrul de cifre ale numrului n. c) Dai un exemplu de numr natural de 4 cifre care,introdus ca valoare pentru n, ar determina afiarea rezultatului 3. d) Scriei un pseudocod echivalent cu cel dat care s conin alt tip de structur repetitiv.

citete n s0 repet dac n MOD 10=s atunci ss+1 n[n/10] pn cnd n=0 scrie s

2. n programul pseudocod alturat se consider c valoarile citite pentru variabilele m si n sunt numere naturale cu cel mult 9 cifre. a) Care este numarul de executii ale instructiunii 5 daca se citeste de la tastatura n=27 si m=75341? b) Ce va afisa algoritmul pentru n=27 si m=75341? c) Scriei un program pseudocod echivalent cu cel dat care s conin alt tip de structur repetitiv.

citete n,m s0 3. cat timp (n>0)sau(m>0) executa 4. dac n MOD 10>m MOD 10 atunci 4. ss+n MOD 10 5. altfel ss+m MOD 10 6. 6. n[n/10] 7. m[m/10] 8. scrie s

1. 2.

3. Fie pseudocodul alturat : a) Care vor fi valorile variabilelor M si P daca la intrare se citesc n=5, iar pentru x valorile 1, 2, 7, 9, 5? b) Scrieti un program pseudocod echivalent care sa utilizeze o structura repetitiva cu test final.

Citeste n,x Mx P1 Pentru i=2,n executa Citeste x Daca M<x atunci Mx Pi scrie M,P

4. Se consider urmtorul algoritm descris n pseudocod: a) Deducei ce se va afia, dac valorile citite ale lui x sunt, n ordine, 2, -3, -6, 4, 8, 16, 0; b) dat; Formulai un enun pentru problema

citeste y citete x nr0 repet dac x=2*y atunci nrnr+1 pn cnd x=0 scrie nr

c) Rescriei secvena folosind o structur repetitiv cu test iniial.

5. Fie pseudocodul alturat : a) Ce se va afia pentru n=6?

b) Rescriei algoritmul, folosind o structur repetitiv cu numr cunoscut de pai

Citeste n dac n=1 sau n=2 atunci t1 altfel a1 b1 i2 ct timp i<n execut ta+b ba at ii+1 scrie t

6. Fie pseudocodul alturat : a) n=3? b) Ce valoare y se va afia pentru x=3 i

Ce realizeaz aceast secven?

Citete x, n y1 contor x Ct timp contor>0 execut yy*n contorcontor-1 Sfrit ct timp Scrie y