Sunteți pe pagina 1din 37

METODA ELEMENTELOR FINITE

Ce este MEF si unde se aplica?


MEF este o metoda generala de rezolvare aproximativa a ecuatiilor
cu derivate partiale care descriu sau nu fenomene fizice.
Principial, MEF consta in studiul pe portiuni ale domeniului de
interes si recompunerea domeniului de studiu, respectand anumite
cerinte matematice.
Din punct de vedere al domeniilor de aplicare, metoda poate fi
extinsa in orice domeniu de activitate, cum ar fi:
- Analiza structurala (determinarea starii de tensiune sau de
deformatie dintr-o structura solicitata);
- Analiza termica (determinarea campului de temperatura sau a
fluxului de caldura dintr-o structura solicitata termic);
- Analiza fluidelor (determinarea functiei de curent sau a
potentialului de viteza);
- Analiza electrica/magnetica (determinarea fluxului electric
sau magnetic).

Aplicatii in analiza termica


Analiza termica presupune in general doua tipuri de calcule,
si anume:
T0
- In regim tranzitoriu

q0

- In regim stationar

T = ct.
Analiza termica stationara (statica) este utilizata pentru
determinarea distributiei de temperatura, gradienti termici si flux
termic in structuri care sunt in echilibru termic. Incarcarile
considerate sunt: flux termic convectiv, flux termic generat, radiatii,
temperaturi impuse etc. Se poate face analiza liniara sau neliniara
Analiza termica tranzitorie este utilizata pentru determinarea
gradientului termic, fluxului termic, in structuri cu incarcari
dependente de timp. Se poate face analiza liniara sau neliniara
T [K]

t [s]

CUNOSTINTE NECESARE UNUI UTILIZATOR M.E.F.


Un utilizator este pus in situatia rezolvarii unei anumite probleme.
Programul de calcul aplicat metodei nu REZOLVA problema ci doar un
MODEL al acesteia, pe care in general il concepe utilizatorul.
Rezultatele pot fi confirmate sau nu, functie de modul in care a fost
ales modelul de calcul.
Modelarea este o activitate de simplificare a structurii prin
incadrarea diverselor portiuni ale structurii in categoria: barelor,
placilor, corpurilor masive, prin considerarea incarcarilor si a
rezemarilor.
Modelarea corecta este o problema de experienta, inspiratie si nu
mai putin de cunoasterea bazelor teoretice ale metodei.
Odata stabilit modelul de calcul, se impune pregatirea datelor de
intrare pentru rezolvarea problemei. Fiecare program de elemente
finite prezinta particularitati care trebuie invatate, dar exista o baza
a metodei, care odata stapanita, permite abordarea oricarui
program de elemente finite.

Tipuri de materiale
Din punct de vedere al proprietatilor pe cele trei directii principale,
materialele se pot califica in:
-Izotrope (materiale care au pe toate direciile, aceleasi proprieti
mecanice, termice etc.)
-Ortotrope
-Anizotrope
O categorie aparte o fac materialele hiperelastice (cauciucul).
Materialele izotrope se caracterizeaza prin trei constante de material E,
G, , cu relatia: E = G/2(1+)
- Materialele ortotrope se caracterizeaza prin 9 constante de material,
corespunzator celor trei directii principale; dintre cele 9 constante, 6 sunt
independente. Acestea sunt: E1, E2, E3, G12, G23, G13, 12, 23, 13.
- Materialele anizotrope se caracterizeaza prin 21 constante elastice
independente..
Material
E [MPa] G [MPa]

Otel

21104

8,1 104

0,3

Fonta

14104

4,5 104

7104

2,7 104

0,24
-

Duraluminiu

Discretizarea
O structura (un domeniu) poate fi impartita in diverse moduri, cu mai
mult sau mai putine noduri si elemente. Nodurile sunt asa-numitele
puncte de lipici, piuneze, care mentin elementele intr-un ansamblu
unitar.

elemente

noduri

MEF a dezvoltat o serie de tipuri


de elemente finite care pentru
inceput pot fi clasificate in:
- Unidimensionale;
- Bidimensionale;
- Tridimensionale
Aceste elemente la randul lor
pot fi impartite in elemente:
- Liniare;
- Parabolice (cuadratice);
- Cubice.

Stabilirea domeniului de analiza


Domeniul de analiza reprezinta un model al corpului (piesei) de studiat.
Acesta se obtine in urma unui proces de idealizare a geometriei corpului
original si uneori de selectie a regiunii de analiza.
Idealizarea este absolut necesara pentru a reduce din complexitatea
configuratiei geometrice a corpului original, pentru a micsora efortul de
pregatire a datelor de intrare si de calcul.
In cazul in care domeniul de analiza reprezinta numai o parte din corpul
original de studiat, o atentie deosebita trebuie acordata adaptarii
conditiilor la limita.
Stabilirea ipotezelor de lucru
Se vor avea in vedere urmatorii parametri:
- Geometria corpului;
- Proprietatile materialelor;
- Domeniul de variatie al principalelor marimi de camp investigate;
- Regimul de functionare (static, dinamic)

Etapele de analiza prin MEF


Programele mari de firma disting trei faze importante de rezolvare a
unei probleme cu ajutorul MEF.
Date de intrare
(Preprocesare)

Procesarea

Datele de iesire
(Postprocesarea)

- Coordonate nodale;
- Tipuri de rezemare;
- Blocaje (conditii la limita);
- Incarcari (mecanice,
termice etc.);
- Proprietati de material;
- Forma, tipul si dimensiunile E.F.

Tensiuni;
Deplasari;
Temperaturi;
Functie de curent;
Flux electric/magnetic

Preprocesarea este etapa de pregatire a datelor de intrare necesara


rezolvarii unei probleme si salvarea lor intr-un fisier de date.
Procesarea consta in rezolvarea efectiva pe cale numerica a modelului
problemei. Datele deja pregatite (in preprocesor) sunt preluate din fisierul
de date si rulate conform tipului de problema.
Postprocesarea este faza de vizionare a rezultatelor in forma tabelara
sau grafica. Aceasta faza permite evaluarea si comentarea rezultatelor.

Factorii de influenta ai discretizarii


O serie de elemente care conditioneaza discretizarea sunt:
-Tipul elementelor finite. Acestea se aleg in functie de tipul
problemei si de domeniul de analiza, de precizia dorita, de variatia
marimii necunoscute etc.
- Elementele parabolice sunt de preferat celor liniare, intrucat la acelasi
numar de noduri, solutia discretizarii cu elemente parabolice este mai
precisa decat cea cu elemente liniare.
- Daca exista mai multe tipuri de elemente finite, la granita dintre
acestea trebuie asigurata continuitatea.
- Marimea si numarul elementelor finite influenteaza convergenta
solutiei. Se observa ca la un numar mai mare de elemente rezultatul se
apropie catre solutia exacta, dar si o crestere excesiva poate conduce
la un colaps datorita efectului erorii de masina la un volum mare de
calcule.
- Pozitionarea nodurilor, care in general se face uniform in
structura. Discontinuitati in geometrie sau in incarcare impun alegerea
unor noduri intermediare. Trecerea de la o zona cu discretizare fina la
una cu discretizare grosolana trebuie facuta progresiv, nu brusc.

Discontinuitate in
geomtrie

Discontinuitati in incarcare

- Gradul de uniformitate a retelei de elemente finite. Se evita


folosirea elementelor cu forma alungita (triunghiuri foarte ascutite,
dreptunghiuri cu raportul dimensiunilor mai mare ca 3). Preferabil ar fi
ca discretizarea cu triunghiuri sa contina numai triunghiuri echilaterale,
discretizarea cu patrulatere sa contina doar patrate, iar cea spatiala cu
elemete de tip BRICK, sa contina cu precadere elemete cubice.
Solutie exacta

NU

DA

Forme bidimensionale de elemente

NE
optim
NE
Influenta NE asupra preciziei

Cateva cuvinte despre programul ANSYS


Ce este ANSYS?
ANSYS este un program de analiza cu elemente finite utilizat pe scara
larga in industrie si cercetare cu scopul de a simula raspunsul unui
sistem fizic solicitat mecanic, termic sau electromagnetic.
Cei 9 pasi de parcurs in rezolvarea unei probleme
Fiecare lansare incepe prin specificarea problemei. Obtinerea solutiei
finale se face prin parcurgerea urmatorilor 9 pasi:
1.
2.
3.
4.
5.
6.
7.
8.
9.

Lansarea programului si setari preliminare;


Precizarea tipului de element si a constantelor ;
Precizarea proprietatilor de material;
Precizarea geometriei modelului;
Discretizarea (mesarea) modelului;
Precizarea conditiilor la limita (conditii de frontiera)
Rezolvarea propriu-zisa (procesarea)
Postprocesarea rezultatelor;
Validarea rezultatelor.

ANSYS utilizeaza meniuri in cascada, reprezentate dupa cum urmeaza:


Main Menu
Models ....

>

Preprocessor

>

Material

Props

>

Material

Fereastra principala este impartita


in cinci regiuni:

Fereastra de iesire

Utility menu Contine functii care sunt


disponibile in intreaga sesiune ANSYS,
cum ar fi controale de fisiere, controale
grafica si alti parametri.
Input Lindow In acest camp sunt
afisate mesajele programului; tot in
acest camp se pot tipari direct
comenzile de executat.
Toolbars Contine butoane
executa comenzile utilizate in
obisnuit.

care
mod

Main menu Contine comenzile


functiilor primare ANSYS, organizate de
preprocesor, procesor si postprocesor si
optimizare.
Graphics window In acest camp sunt
prezentate graficele. Este locul unde
poate fi vizualizat modelul in diferite
stadii precum si rezultatele care decurg
in urma analizei.

Arat textul de ieire din


program, cum ar fi listarea de
date,
etc
De
obicei
este
poziionat n spatele ferestrei
principale i poate fi pus n fa,
dac este necesar.

APLICATIA 1
Pentru sistemul de bare articulate din figura, sa se determine deplasarile nodale,
reactiunile si tensiunile din elementele structurale. Se cunosc: E = 200GPa,
A
= 3250 mm2.

Etapa I Preprocesarea Definirea problemei


In meniul Utility menu se selecteaza comanda File > Change Title:

Va aparea urmatoarea fereastra:

Introduceti titlul si apoi apasati tasta 'OK'.


Acest titlu va aparea in coltul din stanga jos al ferestrei 'Graphics' odata ce demarati
aplicatia.
Nota: Pentru ca titlul sa apara imediat, selectati din Utility Menu > Plot > Replot

Etapa a II-a Introducerea Keypoints


Vom defini define 7 keypoints (puncte nodale)
pentru structura simplificata, dupa cum se poate
observa in tabelul de mai jos:

coordonate
keypoint

Etapa a III-a Din Main Menu se selecteaza:

Preprocessor > Modeling > Create > Keypoints


> In Active CS

1800

3118

3600

5400

3118

7200

9000

3118

10800

Va aparea urmatoarea fereastra:

Pentru a defini primul keypoint care are coordonatele x=0 si y=0 se procedeaza
astfel:
Introduceti keypoint no.1 in casuta de sus; apoi introduceti coordonatele x si y:
0,0 in casutele 2 respectiv 3. Se apasa tasta Apply pentru a fi acceptata comanda
pe care ati dorit-o a fi tiparita.
Introduceti apoi in ordine keypoints 2, 3 etc. cu coordonatele corespunzatoare, in
acelasi mod.
Nota: Atunci cand introduceti ultimul punct (nodul 7), se tasteaza click pe tasta
OK, ceea ce inseamna ca ati terminat operatiunea de introducere a keypoints.
Daca totusi ati apasat Apply pentru acest ultim nod, activati tasta Cancel pentru
a inchide aceasta casuta de dialog.
Nota: Unitatile de masura nu sunt specificate. Pentru lungimi este considerat
implicit [mm]. Este responsabilitatea utilizatorului de a se asigura ca un set de
unitati de masura adecvat este luat in calcul.

Corectarea erorilor. Atunci cand sunt definite keypoints, linii, arii, volume,
elemente, blocaje si incarcari, exista o mare probabilitate de a face erori. Din
fericire, acestea sunt usor de corectat, astfel incat nu trebuie pierdut timpul ori de
cate ori ati comis o greseala. Fiecare meniu Create pentru a genera aceste entitati
variate, are ca optiune si comanda Delete pentru a se putea face corecturile
necesare.

Etapa a IV a Formarea liniilor


Se va utiliza mouse-ul pentru a selecta keypoints-urile care vor defini o linie.
Din Main menu selectati: Preprocessor
> Modeling > Create > Lines > Lines
> In Active Coord.
Va aparea urmatoarea imagine:
Utilizati mouse-ul pentru a selecta keypoint
#1 (faceti click pe acesta). Acesta va fi
marcat printr-o casuta mica galbena.
Va mutati acum cu mouse-ul pe keypoint
#2. O linie care uneste aceste doua puncte
va aparea pe ecran. Daca faceti click
stanga cu mouse-ul, linia va ramane pe
ecran. Se va proceda la fel cu toate
keypoints.

Atunci cand ati terminat de definit toate liniile, apasati OK in fereastra Lines in
Active Coord, minimizati meniurile Lines si Create. Fereastra ANSYS Graphics va
trebui sa arate similar celei prezentate mai jos:

Nota: Orice linie pe care ati creat-o poata sa dispara complet in timpul analizei
propriu-zise. Cu toate acestea, aceste linii nu sunt sterse in realitate. Daca acest
lucru totusi survine in timpul modelarii, din Utility Menu selectati: Plot > Lines.

Etapa a V-a. Definirea tipului de element.


In acest moment trebuie create elementele. Acest procedeu se numeste
meshing. Programul ANSYS doreste sa stie ce tip de elemente finite doriti sa
utilizati.
Din Preprocessor Menu selecati: Element Type > Add/Edit/Delete.
Va aparea urmatoarea fereastra:
Se activeaza tasta Add si
va
aparea
urmatoarea
fereastra:

Pentru acest exemplu, am ales 2D spar element (selectat in figura de mai sus).
Se selecteaza tipul de element apoi se tasteaza OK. Ar trebui sa vedeti Type 1
LINK1 in fereastra Element Types. Se apasa tasta Close in casuta de dialog
Element Types.

Etapa a VI-a. Definirea caracteristicilor geometrice


In meniul Preprocessor, selectati Real Constants > Add/Edit/Delete

Apasati tasta Add si selectati Type 1 LINK1, apoi OK


Va aparea urmatoarea fereastra:

Se introduce aria sectiunii transversale: 3250 si


apoi se apasa tasta OK.
Set 1 apare acum in casuta de dialog. Se
activeaza apoi casuta Close in fereastra Real
Constants, pentru a finaliza actiunea.

Etapa a VII-a. Definirea proprietatilor de material ale elementelor


In meniul Preprocessor, selectati Material Props > Material models

Se face un dublu click pe Structural > Linear > Elastic > Isotropic
Se introduce pentru EX valoarea
200000 (modulul de elasticitate
longitudinal al otelului). Se apasa
apoi pe tasta OK, deoarece pentru
acest tip de problema nu este
necsara valoarea lui PRXY. Se
inchide fereastra Define Material
Model Behavior printr-un click pe
casuta X .

Etapa a VIII-a. Definirea Mesh size


In meniul Preprocessor, selectati Meshing > Size Cntrls > Manual Size >
Lines > All lines

In campul NDIV, introduceti un numar de diviziuni pentru fiecare linie. Pentru


acest exemplu, se doreste numai o singura diviziune pentru o linie. Asadar,
introduceti 1 si apoi OK. Acest lucru nu inseamna ca s-a meshat geometria, ci
doar ca s-au definit dimensiunile elementului.
Pentru meshare, in meniul Preprocessor, selectati Meshing > Mesh > Lines
si faceti click pe Pick All in fereastra Mesh Lines.
Modelul dvs. ar trebui sa apara ca in figura urmatoare:

Pentru a putea vizualiza numarul alocat fiecarui element, keypoint, nod etc. , din
Utility menu (partea de sus a ecranului) se selecteaza PlotCtrls >
Numbering... Bifati casutele corespunzatoare imaginii de mai jos si apoi apasati
tasta OK.
Pentru a salva fisierul din Utility menu se selecteaza comanda File > Save as.
Se atribuie un nume de fisier si locatia in care doriti ca acest fisier sa fie salvat.

Etapa a IX-a. Definirea tipului de incarcare (assigning loads)


si rezolvarea problemei (solving)

Deschideti meniul Solution din ANSYS Main Menu


Definirea tipului de analiza
Din Solution Menu, selectati Analysis Type > New Analysis.
Se selecteaza pentru o
analiza statica comanda
Static, apoi OK.

Selectarea tipurilor de blocaje

In meniul Solution selectati Define Loads > Apply > Structural > Displacement > On Keypoints
Selectati Keypoint 1 printr-un click direct pe Graphics
Window si apoi un OK in fereastra Apply U,ROT on KPs

Aceasta locatie este fixata, ceea ce inseamna ca toate gradele


de libertate (DOF) sunt blocate. Asadar, selectati All DOF
printr-un click pe casuta, introducand valoarea 0 in casuta
Value (deoarece nodul 1 fiind o articulatie sunt blocate atat
deplasarile pe cat si pe Y). Veti vedea triunghiuri albastre in
fereastra grafica, indicand blocajele deplasarilor. Utilizand
acelasi procedeu, se aplica nodului 7 (reazem simplu), deci
blocare numai pe UY. Asadar trebuie deselectat mai intai All
DOF, pentru a selecta apoi casuta UY.

Aplicarea sarcinilor
Selectati Define Loads > Apply > Structural > Force/Moment > on
Keypoints.
Selectati primul Keypoint si apoi faceti click pe OK in fereastra Apply F/M on KPs

Selectati FY in casuta Direction of force/mom. Aceasta indica faptul ca sarcina


va fi aplicata pe directia OY.
Introduceti valoarea de -280000 in casuta Force/moment value si faceti click
pe OK. Valorile implicite pentru unitatea de masura a fortei este [N]. Forta va
aparea in fereastra grafica sub forma unei sageti rosii. Introduceti apoi toate
sarcinile ramase in acelasi mod.

In acest moment fereastra grafica va arata ca in figura de mai jos:

Rezolvarea problemei
In the meniul Solution selectati Solve > Current LS. Va aparea urmatoarea
imagine:

Asigurati-va ca totul este cum ati dorit dvs. apoi tastati OK !


Daca totul este in regula aceasta
fereastra trebuie sa apara pe ecran.

Calculul analitic
Vom calcula mai intai fortele de reactiune din nodurile 7 si 1 si apoi efortul si
tensiunea din elementul 1.

Calculul numeric (utilizand programul ANSYS)


a) Calculul fortelor de reactiune
Din Main Menu se selecteaza General Postproc > List Results > Reaction Solu
Se selecteaza All struc forc F, apoi OK.

Aceste reactiuni
calculate analitic.

coincid

cu

cele

b) Calculul deformatiilor
In meniul General Postproc, selectati Plot Results > Deformed Shape. Va
aparea urmatoarea fereastra:

Selectati casuta Def + undef edge si faceti un click pe OK pentru a vizualiza


atat obiectul deformat si nedeformat. Sistemul deformat este prezentat in
fereastra urmatoare.

Sistemul deformat este colorat in albastru. Se observa ca deformatia maxima


DMX are valoarea 7.409 mm si apare in mod evident. Dupa cum se mai poate
observa, nodul 1 are deplasari nule pe ambele directii, in timp ce nodul 7 nu
sufera deformatie decat pe orizontala.

Pentru o versiune mai detaliata a deformatei sistemului de bare se procedeaza astfel:


Din meniul General Postproc se selecteaza: Plot results > Contour Plot >
Nodal Solution. Va aparea urmatoarea fereastra:

Se selecteaza casutele DOF solution, respectiv USUM, celelalte casute ramanand


nemodificate.

Deformatiile nodale pot fi afisate si sub forma listata. General Postproc > List
Results > Nodal Solution selectati DOF Solution si ALL DOFs din fereastra
List Nodal Solution si apoi faceti un click pe OK. Aceasta inseamna ca dorim
sa vedem lista cu toate gradele de libertate ale solutiei obtinute in urma rularii.

c) Calculul tensiunilor
Din meniul General Postprocessor selectati Element Table > Define Table

Introduceti SAXL in casuta Lab. Apoi, in casutele Item,Comp selectati By


sequence number apoi LS. Apoi introduceti 1 dupa LS, in casuta selectata.
Faceti click pe OK si inchideti fereastra Element Table Data
Afisati tensiunile prin selectarea Element Table > Plot Elem Table.Va aparea
urmatoarea fereastra.

Asigurati-va ca aveti selectata casuta SAXL si apoi OK.


Deoarece ati schimbat intervalele, de la plotarea campului de deplasari, trebuie
sa comutati in Auto calculated pentru a obtine noi valori VMIN/VMAX.
Utility Menu > PlotCtrls > Style > Contours > Uniform Contours ...

Perntru listarea tensiunilor procedati astfel:


Din meniul Element Table, selectati List Elem Table.
Din fereastra List Element Table Data care apare, asigurati-va ca este
activata casuta SAXL. Apsati apoi OK.

Rezultate numerice obtinute

Pentru a parasi programul ANSYS, selectati comanda QUIT din ANSYS


Toolbar sau selectati Utility Menu/File/Exit.... In casuta de dialog, faceti
click pe Save Everything si apoi apasati OK.