Sunteți pe pagina 1din 3

Numele si prenumele____________________________ Data______________ Nota________NR 1

TEST DE VERIFICAREA CUNOSTINTELOR


semestrul I, clasa a IX-a

1. Rezolvati urmatoarele cerinte


a) Scriei n limbaj admis de calculator condiiile pentru ca:
x 30,20 15,10 , unde x este o data de tip numeric;
b) Ce valoare are expresia E= 11*3/2*2/3 ?
2. Care dintre expresiile de mai jos este echivalent cu expresia alturat?
((a>3) AND (a<15)) OR (a<>b)
a. ((a>3) OR (a<15)) AND (a==b)
b. NOT((a<=3) OR (a>=15)) OR (a<>b)
c. ((a>3) OR (a<15)) AND (a<>b)
d. NOT(a<3 OR a>15) AND (a<>b)
3. Ce valoare va avea variabila i dupa executia secventelor de mai jos.
a) i 6 b)i1
cat timp i< 6 executa cat timp i<=2 executa
i i+1 i i + 1
scrie i scrie
i
4. Fie n un numr natural cu exact 3 cifre. Scrieti o expresie ce poate fi atribuit variabilei n
astfel nct cifra 5 s fie inserata penultima. De exemplu : pentru n=123 dac variabilei n
i se atribuie expresia cerut atunci valoarea lui n va fi 1253.
5. Se considera urmatorul algoritm scris in pseudocod.
Inceput
Citeste n
z0 a) Scrieti valoarea ce se va afisa daca se citeste
p1 n = 103456
cat timp (n>0) executa
inceput cn % 10
nn / 10
daca (c % 3=0)
Inceput zz+p*(9-c)
pp*10
Sfarsit
Sfarsit
scrie z
Sfarsit

6. Realizati un algoritm care calculeaza perimetrul si diagonala unui patrat de latura a,


numar intreg citit de la tastaura.
7. Se citeste de la tastatura un numar a de cinci cifre. Sa se afiseze numarul daca
numarul de cifre pare este mai mare decat numarul de cifre impare, altfel se va afisa un
mesaj de eroare. (ex a= 12345 atunci se va afisa mesaj de eroare, iar daca numarul
a=24784 atunci se va afisa 24784)

Barem de corectare
Subiectul 1.a 1.b 2 3.a 3.b 4 5 6 7 oficiu

Punctaj 10 10 10 5 5 10 15 10 15 10
Numele si prenumele____________________________ Data______________ Nota________NR 2
TEST DE VERIFICAREA CUNOSTINTELOR
semestrul I, clasa a IX-a

1. Rezolvati urmatoarele cerinte:


a) Scriei n limbaj admis de calculator condiiile pentru ca:
x 30, 20 30, , unde x este o data de tip numeric;
b) Care este valoarea expresiei alturate? E = 9/2*2*5-5
2. Care dintre expresiile de mai jos este echivalent cu expresia alturat?
NOT((a<5)AND(b>7))
a. (a>=5)AND(b<=7)
b. NOT(a<5) OR NOT(b>7)
c. NOT(a<5) AND NOT(b>7)
d. NOT(a>=5) AND NOT(b<=7)
3. Ce valoare va avea variabila x dupa executia secventelor
a) x 6 b)x2
cat timp x<=5 executa cat timp x<=3 executa
x x + 2 xx+2
scrie x
scrie x
4. Fie n un numr natural cu exact 4 cifre. Scrieti o expresie ce poate fi atribuit variabilei n
astfel nct cifra 7 s fie inserata la mijlocul numarului. De exemplu : pentru n=1234 dac
variabilei n i se atribuie expresia cerut atunci valoarea lui n va fi 12734.
5. Se considera urmatorul algoritm scris in pseudocod.
Inceput
Citeste n (numar natural)
an% 10
ma a) Scrieti valoarea ce se va afisa daca se citeste numarul
cat timp (n>9) executa 16389
Inceput
n n /1 0
b n %1 0
daca (a>b) atunci
inceput
mm*10+b
ab
sfarsit
sfarsit
scrie m
sfarsit

6. Realizati un algoritm care calculeaze aria si diagonala uuni dreptunghi stiind


laturile dreptunghiului L si l numere intregi date de la tastaura
7. Se dau doua numere a si b de trei cifre fiecare. Sa se afiseze numarul care are cel
mai mare numarul de cifre pare. (ex: a=123 si b=245 se va afisa 245)
Barem de corectare
Subiectul 1.a 1.b 2 3.a 3.b 4 5 6 7 oficiu

Punctaj 10 10 10 5 5 10 15 10 15 10
Numele si prenumele____________________________ Data______________ Nota________NR 3

Barem de corectare
Subiectul 1.a 1.b 2 3.a 3.b 4 5 6 7 oficiu

Punctaj 10 10 10 5 5 10 15 10 15 10