Sunteți pe pagina 1din 21

Varianta 1 :

citeşte n (număr natural) #include <iostream>


z=0 using namespace std;
p=1 int main()
┌cât timp n>0 execută {
│ c=n%10 int n,z=0,p=1,c;
│ n=[n/10] cout<<"Numar =";cin>>n;
│┌dacă c%3=0 atunci while (n!=0)
││ z=z+p*(9­c) {
││ p=p*10 c=n%10;
│└■ n=n/10;
└■ if (c%3==0)
scrie z {
z=z+p*(9-c);
p=p*10;
}
a)963
}
b)61, 65, 67
cout<<"Numar
c)citeste n
nou="<<z<<endl;
z<-0
return 0;
p<-1
}
daca n>0 executa
┌repeta
│c<-n%10
│n<-[n%10]
│daca n%3=0
│ │z<-z+p*(9-c)
│ │p<-p*10
│ └■
│ pana cand n<=0
└■
scrie z
Varianta 2: #include <iostream>
citeşte x (număr natural using namespace std;
nenul) int main()
┌cât timp x>0 execută {
│ citeşte y (număr int x,y,c;
natural) cout<<"Numar=";cin>>x;
│┌dacă x>y atunci while (x>0)
││ scrie x%10 {
││altfel cout<<"Y=";cin>>y;
││ scrie y%10 if (x>y)
│└■ {
│ x=y c=x%10;
└■
cout<<"C="<<c<<endl;
}
else
a)2 2 1 1 7 7 5 {
b)19 18 17 7 0 c=y%10;

cout<<"C="<<c<<endl;
}
x=y;
}
return 0;
}
Varianta 3 :
citeşte z,x #include <iostream>
(numere naturale nenule) using namespace std;
┌cât timp x>0 execută int main()
│ citeşte y (număr {
natural) int z,x,y,c;
│ ┌dacă z<y­x atunci cout<<"X=";cin>>x;
│ │ scrie x%10 cout<<"Z=";cin>>z;
│ │altfel while (x>0)
│ │ scrie y%10 {
│ └■
│ x=y
└■ cout<<"Y=";cin>>y;
if (z<y-x)
{
c=x%10;
a)2 9 2 3 5 0
b)1 7 9 3 1 0 cout<<"C="<<c<<endl;
}
else
{
c=y%10;

cout<<"C="<<c<<endl;
}
x=y;
}
return 0;
}
Varianta 4: #include <iostream>
citeşte a,b (numere using namespace std;
întregi) int main()
┌dacă a<b atunci {
│ a↔b int a,b,aux,x;
└■ cout<<"A=";cin>>a;
┌pentru x=a,b,­1  cout<<"B=";cin>>b;
execută if (a<b)
│ ┌dacă x%2≠0 atunci {
│ │ scrie x,’ ’ aux=a;
│ └■ a=b;
└■ b=aux;
}
for (x=a;x>=b;x--)
{
a)16 14 12 10 8 6 if(x%2==0)
b)(0,-10), (1,-10), (1,-11),
(0,-11), (-10,0), (-10,1), (- cout<<"X="<<x<<endl;
11,1), (-11,0) }
return 0;
}
Varianta 5 : #include <iostream>
citeşte x,z (numere using namespace std;
naturale) int main()
y=0 {
┌repetă int x,z,y,c,d;
│ y=y*10+x%10 cout<<"X=";cin>>x;
│ x=[x/100] cout<<"Z=";cin>>z;
└până când x=0 do
{
┌cât timp y*z>0 şi y
y=y*10+x%10;
%10=z%10 execută
x=x/100;
│ y=[y/10] }
│ z=[z/10] while (x!=0);
└■ c=y%10;
┌dacă y+z=0 atunci d=z%10;
│ scrie 1 while (y*z>0 && c=d)
│altfel {
│ scrie 0 y=y/10;
└■ z=z/10;
c=y%10;
d=z%10;
a)1 }
b)890 if (x+z=0)
cout<<"1"<<endl;
else
cout<<"0"<<endl;
}
#include <iostream>
Varianta 6: using namespace std;
int main()
citeşte n (număr natural)
{
s=­1
int n,s=-1;
┌cât timp n>0 execută cout<<"Numar=";cin>>n;
│┌dacă n%10>s atunci while (n!=0)
││ s=n%10 {
││altfel if(n%10>s)
││ s=11 s=n%10;
│└■ else
│ n=[n/10] s=11;
└■ n=n/10;
scrie s }
cout<<"S="<<s<<endl;
return 0;
a)9 }
b)orice numar care  
nu are cifrele in 
ordine descrescatoare
#include <iostream>
Varianta 7: using namespace std;
citeşte n (număr natural int main()
nenul) {
nr=0 int n,nr=0,a,m;
┌pentru a=9,0,­1  cout<<"N=";cin>>n;
execută for (a=9;a>=0;a--)
│ m=n {
│┌cât timp m≠0 şi m m=n;
while (m!=0 && m
%10≠a execută %10!=a)
││ m=[m/10] m=m/10;
│└■ if (m!=0)
│┌dacă m≠0 atunci nr=nr*10+m%10;
││ nr=nr*10+m%10 }
│└■
└■ cout<<"Numar="<<nr<<endl;
scrie nr return 0;
}

a)9432
b)69645 şi 55946
#include <iostream>
Varianta 8: using namespace std;
int main()
citeşte n,k (numere
{
naturale nenule) int n,k,nr=0,p=1;
nr=0 cout<<"N=";cin>>n;
p=1 cout<<"K=";cin>>k;
┌cât timp n≠0 şi k≠0  while (n!=0 && k!=0)
execută {
│┌dacă n%2=0 atunci if (n%2==0)
││ nr=nr+ n%10*p nr=nr+n%10*p;
││ p=p*10 else
││altfel k=k-1;
││ k=k­1 n=n/10;
│└■ }
│ n=[n/10]
└■ cout<<"Numar="<<nr<<endl;
scrie nr return 0;
}

a)22
b)7935 şi orice k (orice
număr cu toate
cifrele impare)
#include <iostream>
using namespace std;
Varianta 9: int main()
citeşte n (număr natural) {
s=10 int n,s=10;
┌cât timp n>0 execută cout<<"N=";cin>>n;
│┌dacă n%10<s atunci while (n!=0)
││ s=n%10 {
││altfel if (n%10<s)
││ s=­1 s=n%10;
│└■ else
│ n=[n/10] s=s-1;
└■ n=n/10;
scrie s }
cout<<"S="<<s<<endl;
return 0;
a)1 }
b)2317 (orice număr care
nu are cifrele in ordine
cresc.)
#include <iostream>
using namespace std;
int main()
Varianta 10: {
citeşte n,k int n,nr=0,k,p=1;
(numere naturale nenule) cout<<"N=";cin>>n;
nr=0 cout<<"K=";cin>>k;
p=1 while (n!=0 && k!=0)
┌cât timp n≠0 şi k≠0  {
execută if (n%2==0)
│┌dacă n%2≠0 atunci {
││ nr=nr + [n/10]%10*p
nr=nr+n/10*10*p;
││ p=p*10
p=p*10;
││altfel
}
││ k=k­1 else
│└■ k=k-1;
│ n=[n/10] n=n/10;
└■ }
scrie nr
cout<<"Numar="<<nr<<endl;
return 0;
a)24 }
b)23145
#include <iostream>
using namespace std;
int main()
{
Varianta 11: int n,k,p=1,c;
citeşte n,k (numere cout<<"N=";cin>>n;
naturale) cout<<"K=";cin>>k;
p=1 while (k>0 && n>0)
┌cât timp n>0 şi k>0  {
execută c=n%10;
│ c=n%10 if (c%2==0)
│ ┌dacă c%2=1 atunci p=p*c;
│ │ p=p*c n=n/10;
│ └■ k=k-1;
}
│ n=[n/10]
cout<<"P="<<p<<endl;
│ k=k­1
return 0;
└■
}
scrie p

a)8
b) 54628 (orice nr. cu
ultimele 4 cif pare)
#include <iostream>
using namespace std;
int main()
{
Varianta 12: int x,y=0;
citeşte x cout<<"X=";cin>>x;
(număr natural) while (x!=0)
y=0 {
┌cât timp x≠0 execută while (x>9)
│ ┌cât timp x>9  x=x/10;
execută y=y*10+x;
│ │ x=[x/10] cout<<"X=";cin>>x;
│ └■ }
│ y=y*10+x cout<<"Y="<<y<<endl;
│ citeşte x }
└■
scrie y

a)17396
b)370 29 17 0
#include <iostream>
using namespace std;
int main()
{
Varianta 13: int a,b,c,k=0,i;
citeşte a,b cout<<"A=";cin>>a;
(numere naturale, a≤b) cout<<"B=";cin>>b;
k=0 for (i=a;i<=b;i++)
┌pentru i=a,b execută {
│ n=i; c=0 n=i;
│ ┌cât timp n>0  c=0;
execută while (n!=0)
│ │ ┌dacă n%2=1  {
atunci if (n%2==1)
│ │ │ c=c+1 c=c+1;
│ │ └■ n=n/10;
│ │ n=[n/10] }
│ └■ if (c>0)
│ ┌dacă c>0 atunci k=k+1;
}
│ │ k=k+1
cout<<"K="<<k<<endl;
│ └■
return 0;
└■
}
scrie k

a)7
b)61 62
#include <iostream>
using namespace std;
int main()
{
Varianta 14: int x,n=0,y,c;
citeşte x cout<<"X=";cin>>x;
(număr natural) while (x!=0)
n=0 {
┌cât timp x≠0 execută y=x;
│ y=x; c=0 c=0;
│ ┌cât timp y>0  while (y!=0)
execută {
│ │ ┌dacă y%10>c  if (y%10>c)
atunci c=y%10;
│ │ │ c=y%10 y=y/10;
│ │ └■ }
│ │ y= [y/10] n=n*10+c;
│ └■ cout<<"X=";cin>>x;
│ n=n*10+c }
│ citeşte x
└■ cout<<"Numar="<<n<<endl;
scrie n return 0;
}

a)27596
b)371 35 211 0
#include <iostream>
using namespace std;
int main()
{
int a,n,i;
Varianta 15: cout<<"A=";cin>>a;
citeşte a,n cout<<"N=";cin>>n;
(numere naturale) for (i=1;i<=n;i++)
┌pentru i=1,n execută {
│ ┌dacă i%2=0 atunci if (i%2==0)
│ │ a=a­i*i a=a-i*i;
│ │altfel else
│ │ a=a+i*i a=a+i*i;
│ └■ }
└■ cout<<"A="<<a<<endl;
scrie a return 0;
}

a)4
b)n=4
#include <iostream>
using namespace std;
int main()
{
int n,i,j;
cout<<"N=";cin>>n;
for (i=1;i<=n-1;i++)
Varianta 16: {
citeşte n (număr natural if (i%2==0)
nenul) cout<<"#"<<endl;
┌pentru i=1,n­1  for (j=i+1;j<=n;j++)
execută {
│┌dacă i%2=0 atunci
││ scrie ’#’ cout<<"*"<<endl;
│└■ }
}
│┌pentru j=i+1,n 
return 0;
execută
}
││ scrie ’*’
│└■
└■

a)***#***
b)12
#include <iostream>
using namespace std;
int main()
{
int x,y;
cout<<"X=";cin>>x;
Varianta 17: cout<<"Y=";cin>>y;
if (x<y)
citeşte x,y {
(numere naturale) x=x-y;
┌dacă x<y atunci y=x+y;
│ x=x­y x=y-x;
│ y=x+y }
│ x=y­x while (x>=y)
└■ {
┌cât timp x≥y execută cout<<"A"<<endl;
│ scrie ’A’ x=x-y;
│ x=x­y cout<<"B"<<endl;
│ scrie ’B’ }
└■ return 0;
}

a)ABABABAB
b)6 perechi
#include <iostream>
using namespace std;
int main()
{
int x,y,aux;
cout<<"X=";cin>>x;
Varianta 18: cout<<"Y=";cin>>y;
if (x>y)
citeşte x,y {
(numere naturale) aux=x;
┌dacă x>y atunci x=y;
│ y=x y=aux;
└■ }
┌dacă x%2=0 atunci if (x%2==0)
│ x=x+1 x=x+1;
└■ while (x<=y)
┌cât timp x≤y execută {
│ x=x+2 x=x+2;
│ scrie ‘*’ cout<<"*"<<endl;
└■ }
return 0;
}
a)****
b)0 si 1
#include <iostream>
using namespace std;
int main()
{
int a,b,i,c,x;
cout<<"A=";cin>>a;
Varianta 19: cout<<"B=";cin>>b;
citeşte a,b a=a/10%10*10+a%10;
(numere naturale) b=b/10%10*10+b%10;
a=[a/10]%10*10+a%10 for (i=a;i<=b;i++)
b=[b/10]%10*10+b%10 {
┌pentru i�a,b execută c=i%10;
│┌dacă[i/10]=i%10  x=i/10;
atunci if (x=c)
││ scrie i%10 {
│└■
└■ cout<<"c="<<c<<endl;
}
}
a)234 return 0;
b)312 335 }
#include <iostream>
using namespace std;
int main()
{
int n,a,m,b;
Varianta 20: cout<<"N=";cin>>n;
a=n%10;
citeşte n (număr natural) m=a;
a=n%10 while (n>9)
m=a {
┌cât timp n>9 execută n=n/10;
│ n=[n/10] b=n%10;
│ b=n%10 if (a>b)
│┌dacă a>b atunci {
││ m=m*10+b m=m*10+b;
││ a=b a=b;
│└■ }
└■ }
scrie m cout<<"M="<<m<<endl;
return 0;
}
a)9831
b)3210