Sunteți pe pagina 1din 6

Algoritmi

 Definiție

O succesiune finită de operații care pornind de la anumite date de intrare să


producă rezultate numite date de ieșire.

Spre exemplificare:

Orice activitate zilnică se realizează pe baza unui algoritm.

Operația de împărțire a două numere se realizează pe baza unui algoritm (În


urma împărțirii deîmpărțitului la împărțitor se obține un cât și un rest. Operația
se realizează în etape și se execută într-un număr finit de pași).

 Proprietăți

1. Generalitatea

Orice algoritm trebuie să rezolve o clasă de probleme.

2. Corectitudinea

Algoritmul realizat trebuie să furnizeze rezultate corecte.

3. Claritatea

Algoritmul este descris clar fără ambiguități.

4. Finititudinea

Orice algoritm furnizează rezultate într-un timp finit și în urma parcurgerii


unui număr finit de pași.

• Date. Informații

 Noțiunea de dată și informație

Datele

Datele sunt lucruri abstracte și pot fi numere, texte, imagini.


În urma prelucrării datelor se obține informația. Datele nu sunt certe însă
informațiile sunt certe.

Din punct de vedere informatic, datele de intrare sunt supuse prelucrării


obținându-se date de ieșire numite rezultate (informația).

Spre exemplificare: 2+3=5

În exemplu dat, datele (de intrare) sunt reprezentate de numerele 2 si 3.

Rezultatul prelucrării datelor (operația de adunare) este 5 (informația-dată


de ieșire).

Exemplu de algoritm

Verificarea unui număr dacă este par.

Condiția ca un număr să fie par este ca restul împărțirii numărului la 2 să


fie egal cu 0.

Date de intrare: numărul a cărui paritate se verifică: n

Prelucrarea dacă restul împărțirii numărului la 2 =0 (daca n%2==0) atunci


numărul este par

Rezultatul: numărul este par

Date de
Prelucrare ieșire
Date de
intrare (rezultate)

Dispozitive periferice de intrare Dispozitive periferice de ieșire

Reprezentarea algoritmilor:

- Limbaj natural (de exemplu, în limba română)


- Schemă logică (reprezentare grafică)
- Pseudocod
Reprezentarea algoritmului de determinare a unui număr par

 Reprezentare în limbaj natural

Pas I Start
Pas II Citește numărul n
Pas III Dacă restul împărțirii numărului la 2 este 0 atunci
Pas III.1.1 scrie “Numărul este par”
altfel
PAS III.1.2 scrie “Numărul este impar”

Pas IV STOP

 Reprezentare în schemă logică

Start

Citește n

NU DA
N%2==0

Scrie Scrie
“numărul”, n, “numărul”, n,
„este impar” „este par”

Stop Stop
 Reprezentare în Pseudocod

Start

Citește n

Dacă n% 2==0 atunci

scrie “Numărul este par”

altfel

scrie “Numărul este impar”

STOP

Raptor

Explicații
Se introduce numărul:24
Verifică dacă nr este par sau nu (restul impartirii lui 24 la 2 este 0???)
Daca da afisează Număr par
Dacă nu afișează Numar impar
Noțiunea de variabilă

Proprietatea algoritmilor: Generalitatea

Orice algoritm trebuie să rezolve o clasă largă de probleme.

În exemplul anterior Indiferent de valoarea introdusă de la tastatură trebuie să se


furnizeze un rezultat : Număr par sau Număr impar

Cu alte cuvinte valoarea introdusă de la tastatură nu este constantă ci este


variabilă.

Întrebări recapitulative

Stabiliți valoarea de adevăr a următoarelor enunțuri:

a) Un algoritm este o metodă de gândire


b) Un algoritm este util dacă rezolvă o problemă particulară
c) Un algoritm trebuie descris clar, fără ambiguități

Selectați varianta corectă. Un algoritm este:

a) Un set de date care sunt executate într-o succesiune logică


b) O metodă ce se aplică unui set finit de date de intrare/ieșire
c) Un procedeu de calcul ce trebuie să dea o soluție la o clasă generală de
probleme
d) O succesiune de operații ce se derulează într-un număr finit de pași.

Selectați varianta corectă. Pseudocodul este:

a) codificare ce furnizează rezultate greșite


b) Un cod care nu este folosit
c) Un limbaj pentru descrierea algoritmilor
d) Nici un răspuns anterior nu este corect

Selectați varianta corectă. O schemă logică este:

a) Un desen tehnic
b) Un set de figuri geometrice
c) Un mod de a descrie algoritmi
d) Nici un răspuns anterior nu este corect