Sunteți pe pagina 1din 47

Introducere n Informatic

Capitolul 9. Editorul de texte Microsoft WORD


9.1. Introducere Editorul profesional de texte Word face parte din pachetul de aplicaii Microsoft Office, mpreun cu aplicaiile Excel (program de calcul tabelar), Access (sistem de gestiune al bazelor de date) i Power Point (program de grafic pentru realizarea prezentrilor pe computer). Acest editor profesional de texte ofer utilizatorului urmtoarele faciliti de lucru: 1. crearea, corectarea i manipularea documentelor; 2. lucrul simultan cu mai multe documente; 3. tiprirea documentelor; 4. operaii de copiere, mutare, tergere i refacere a blocurilor de texte; 5. operaii de cutare i nlocuire (cu confirmare sau automat) a unor poriuni de texte; 6. operaiuni de formatare a documentului att la nivel de caracter ct i la nivel de paragraf; 7. operaiuni de utilizare i administrare att a unor stiluri de formatare predefinite (aflate n pachetul Word), ct i a unor stiluri de formatare definite de utilizator; 8. operaiuni de formatare a documentului la nivel de pagin, pentru stabilirea dimensiunilor marginilor paginii, crearea i gestionarea notelor de subsol sau de sfrit, crearea i gestionarea antetelor de nceput sau sfrit de pagin, gestionarea i setarea numrului de pagin; 9. administrarea i manipularea unor abloane predefinite sau create de utilizator, pentru automatizarea procesului de formatare a unui document; 10. operaiuni de creare, modificare, formatare i inserare a tabelelor; 11. operaiuni de formatare a documentului pe mai multe coloane; 12. operaiuni de creare a unor liste marcate i/sau numerotate; 13. crearea tabelelor de cuprins, index, de obiecte (figuri, imagini, sunete, diagrame); 14. inserarea de figuri, imagini, sunete, diagrame, ecuaii i desene n documentele cu care lucreaz utilizatorul; 15. administrarea corespondenei: scrisori i adrese (etichete) potale; 16. crearea, modificarea i folosirea macrourilor (programe n Word Basic aproape identic cu Visual Basic). Extensia implicit asociat de editorul profesional de texte Word, documentelor cu care lucreaz, este .doc. Word poate procesa documente

151

Introducere n Informatic

create cu ajutorul altor editoare de texte, iar documentele create cu editorul Word pot fi salvate n foarte multe alte formate n vederea exploatrii lor cu alte editoare. Altfel spus, Word permite importul sau exportul de fiiere document. Datorit mbuntirilor sale continue, editorul de texte Word a devenit, n momentul de fa, cel mai popular i mai utilizat program de tehnoredactare. Utilizarea protocolului OLE (Object Linking and Embedding Legarea i nglobarea obiectelor) permite inserarea obiectelor aflate n memoria dinamic clipboard, pentru crearea legturilor dinamice ce se actualizeaz automat. Acest protocol funcioneaz pentru toate aplicaiile care au fost proiectate pe platforme Windows. 9.1.1. Elementele componente ale documentului Un document Word se compune din urmtoarele entiti de document: Seciunea (Section): este reprezentat de o zon compact din cadrul unui document care poate fi formatat diferit de restul documentului; Coloana (Column): este un bloc vertical parcurs continuu la citire i separat de alt bloc vertical aparinnd aceleiai pagini a documentului; Tabelul (Table): este o zon din spaiul util al documentului, mprit n linii i coloane la intersecia crora se gsesc nite csue numite celule, care pot conine obiecte sau formule de calcul; Legenda (Caption): este o etichet care se atribuie ntotdeauna obiectelor (figuri, desene, ecuaii matematice, diagrame, imagini) inserate n documentul curent, ele se utilizeaz pentru a numerota obiectele inserate i ele pot fi utilizate la construirea tabelei index de obiecte; Titlul capitolului (Heading): este reprezentat de un text de la nceputul unui paragraf care definete titlul capitolului, el putnd fi formatat cu un stil predefinit, pe baza lui se poate realiza cuprinsul documentului curent; Cadrul (Box): este o caset, de regul dreptunghiular, care ncapsuleaz un obiect aparinnd documentului (diagram, desen, ecuaie matematic) i care faciliteaz o manipulare uoar a obiectelor inserate n document; Nota de subsol (Footnote): este reprezentat de un text inserat la subsolul paginii pentru specificarea referinelor la textul din pagina curent;

152

Introducere n Informatic

Nota de sfrit (Endnote): este reprezentat de un text inserat la sfritul documentului pentru specificarea referinelor la textul din document; Adnotarea (Adnotation): este reprezentat de un text inserat de utilizator n document i care are rol de comentariu, el nefiind niciodat tiprit, avnd doar scop de informare a utilizatorului; Codul cmpului (Field): este instruciunea inserat automat de ctre Word la execuia unei comenzi, sau la cererea expres a utilizatorului. 9.1.2. Instrumente gramaticale utilizate de Word Editorul profesional Word pune la dispoziia utilizatorului o serie de faciliti de asistare gramatical la realizarea documentului: Verificarea automat a ortografiei (Spelling) : este o facilitate puternic pus la dispoziia utilizatorului n timpul introducerii sau corectrii textului; ea const n verificarea n fundal a textului introdus, din punct al verificrii ortografiei; pn la versiunea Word 2000, se fcea verificarea ortografic doar a textului introdus n limba englez, dar de la aceast versiune se verific ortografic n mai multe limbi printre care i n limba romn; Verificarea gramatical (Grammar): editorul Word este capabil s verifice ntregul text, sau numai textul selectat, dac este sau nu corect din punct de vedere sintactic (inclusiv desprirea n silabe), editorul Word 2000 asigur aceast facilitate i pentru textul introdus n limba romn; Corectarea automat (AutoCorrect): ne permite corectarea automat a unor greeli, prin efectuarea unui click dreapta pe cuvntul eronat caz n care se deschide o list cu propuneri de cuvinte din care o alegem pe cea corect; Dicionar de sinonime i antonime (Thesaurus): asigur afiarea sinonimelor i antonimelor cuvntului selectat. 9.1.3. Limbajul de programare WordBasic Procesorul profesional de texte Word este distribuit mpreun cu un limbaj propriu de programare numit WordBasic. Acest limbaj de programare este special destinat construirii macrourilor care sunt rutine de automatizare a procesului de prelucrare i procesare a textelor Word. ntr-un macrou sunt nregistrate acele operaii executate de utilizator prin intermediul sistemului de meniuri, cum sunt: editarea unui text, formatarea

153

Introducere n Informatic

acestuia, inserarea de obiecte etc. Toate operaiile care construiesc macrourile sunt descrise prin intermediul instruciunilor limbajului de programare WordBasic. Sunt anumite secvene de operaiuni pe care utilizatorul trebuie s le execute de mai multe ori n timpul unui text sau a mai multor documente. n acest caz este extrem de productiv s-i realizeze un macrou, i ori de cte ori dorete s execute respectiva secven de operaiuni va cere procesorului de texte s execute macroul n care sunt memorate instruciunile WordBasic care simuleaz secvena de operaii. Acest limbaj este extrem de uor pentru cei care cunosc: Qbasic, Visual Basic sau VBA. Pentru programarea macrourilor WordBasic dispune de urmtoarele elemente de limbaj: 1. Operatori: utilizai pentru definirea i construirea expresiilor, sunt utilizai operatorii aritmetici, relaionali, logici i cei de concatenare a irurilor; 2. Instruciuni pentru descrierea structurilor de program : sunt cele care asigur materializarea algoritmului de descriere a secvenei de operaii, ordinea de execuie a instruciunilor macroului este n general secvenial, dar sunt permise i structuri alternative de tipul If Then Else i Select Case End Select, precum i structuri repetitive While Wend i For Next; din limbajul Basic clasic s-a luat i identificarea cu etichete liniilor surs, de aceea se poate i utiliza instruciunea de salt necondiionat GoTo; 3. Instruciuni care corespund opiunilor de meniuri: exist o coresponden biunivoc ntre cuvintele cheie ale acestor instruciuni i opiunile de meniu, de exemplu pentru opiunea Open din File se utilizeaz instruciunea FileOpen, pentru opiunea Close din File se utilizeaz instruciunea FileClose etc. 4. Instruciuni pentru schimbul de informaii : utilizate pentru a crea pe ecranul calculatorului diverse obiecte, cum sunt declanatoare, casete de dialog, zone de editare etc, cu ajutorul crora utilizatorul va putea diverse informaii macroului; aa de exemplu, pentru a crea o list se folosete instruciunea ListBox, pentru a crea un declanator de tip OK se folosete instruciunea OKButton, pentru a crea un declanator de tip Cancel se folosete instruciunea CancelButton, pentru a crea un buton radio de tip Option se folosete instruciunea OptionButton . a. m. d; 5. Funcii: simularea operaiunilor se realizeaz prin intermediul instruciunilor sau a funciilor, funcii care uneori pot au acelai nume cu instruciunile: pentru a seta dimensiunea fonturilor unui text selectat se poate folosi instruciunea FontSize, pe cnd funcia

154

Introducere n Informatic

FontSize() returneaz o valoare numeric ce reprezint dimensiunea caracterelor din zona selectat; pentru a seta fonturile de tip Bold textului selectat se poate folosi instruciunea Bold, pe cnd funcia Bold() testeaz dac stilul caracterelor zonei selectate este Bold ori nu; sunt ns i funcii pure ca de exemplu: pentru returnarea prii ntregi a unui numr se folosete funcia Int(), pentru generarea unui numr aleatoriu ntre 0 i 1 se folosete funcia Rnd(), pentru extragerea unui subir din partea stng a unui ir se folosete funcia Left$(), pentru extragerea unui subir din partea dreapt a unui ir se folosete funcia Right$(), pentru extragerea unui subir din partea central a unui ir se folosete funcia Mid$(), pentru extragerea lungimii irului se folosete Len$() . a. m. d. Ca exemplu, s presupunem c dorim s proiectm un macrou care pentru o zon selectat naintea apelului s solicite dimensiunea fontului (ntre 8 i 72) si n plus s i afieze caracterele de tip bold, acest macrou are numele Bolduire. Sursa n WordBasic este urmtoarea:
Sub Bolduire() ' ' Bolduire Macrocomanda ' Macrocomanda nregistrata 8/16/01 de Joldes ' h = Val(InputBox$("Introduceti dimensiunea fontului (valoare numeric ntre 8 ... 72)")) Selection.Font.Size = h Selection.Font.Bold = wdToggle End Sub

Dup lansarea n execuie a macroului se va afia caseta:

Fig. 9.1. Introducerea dimensiunii fontului n care utilizatorul va introduce prin tastare dimensiunea fontului pentru zona selectat. Valoarea tastat trebuie s se ncadreze ntre limitele cerute de mesajul din caset. Confirmarea introducerii valorii se face prin efectuarea unui click pe butonul OK. Valoarea tastat este recepionat ca un

155

Introducere n Informatic

ir de caractere, de aceea pentru obinerea valorii numerice pentru nlimea h se aplic funcia Val() care are rolul de evaluare numeric a irului introdus. Prin instruciunea Selection.Font.Size = h se atribuie fontului dimensiunea dorit de utilizator, iar prin instruciunea Selection.Font.Bold = wdToggle se atribuie atributul Bold pentru zona selectat. Pentru definirea macrocomenzii se selecteaz din meniul Tools opiunea Macros i subopiunea Play New Macro i se obine caseta de dialog:

Fig.9.2. Macrocomand de bolduire

Fig. 9.3. Particularizarea barei de instrumente

156

Introducere n Informatic

n aceast caset de dialog se introduce numele macroului pe care dorim s-l crem. Acest macrou poate fi introdus n bara de instrumente sau poate fi apelat de la tastatur cu o combinaie de taste. Ea poate fi valabil pentru toate documentele sau numai pentru documentul curent. Pot s apar diverse particularizri pe care le alegem din caseta Custom: Tool Bars (Bare de instrumente): in care se pot seta barele de instrumente sau se pot reiniializa, terge sau redenumi Commands (Comenzi):

Fig. 9.4. Particularizare comenzi Options (Opiuni):

157

Introducere n Informatic

Fig.9.5. Particularizare opiuni Particularizri de iniializare a Word-ului

Fig. 9.6. Particularizri de iniializare Pe toat perioada ct se introduc comenzile ce compun macroul de afieaz caseta de instrumente specifice macrourilor:

O dat cu nchiderea macroului, caseta dispare i se poate avea acces la utilizarea macroului i la modificarea lui. 9.2. WORD 2000 Programul Word 2000 este unul din cele mai flexibile i mai puternice dintre programele de procesare de texte. Word ofer toate uneltele necesare pentru a crea orice tip de document, de la un text de o singur pagin, la un raport complicat cu 500 de pagini. innd seama c exist o variant Word 2000 cu meniurile n limba romn i una n limba englez, vom prezenta principalele funcii mai ales pentru varianta n limba englez. Considerm c, dac se cunoate operarea cu aceast variant, este relativ uor s se utilizeze varianta n limba romn. 9.2.1. Lansarea n execuie a programului

158

Introducere n Informatic

Similar altor aplicaii din Windows, Word poate fi lansat n mai multe moduri: dac este afiat Microsoft Office Manager (MOM), se face clic pe butonul W dac este creat o iconi pentru Word pe desktop se face dublu clic pe ea dac nu este ndeplinit nici una din condiiile anterioare, se va face lansarea din butonul StartProgramsW(ord). A. Prile componente ale ecranului Figura 9.7 prezint ecranul Word 2000 pentru varianta n limba englez, iar figura 9.8 pentru varianta n limba romn. Elementele constitutive sunt: Bara de titlu - afieaz numele programului i numele documentului Bara de meniuri- conine meniul principal al programului Bara de unelte standard- afieaz butoane care pot fi selectate pentru a realiza rapid diferite activiti de editare; poate fi folosit numai cu ajutorul mouse- ului Bara cu unelte de formatare a textului - se folosete pentru a selecta comenzi de formatare pentru caracterele selectate Rigla- afieaz marginile documentului, alinierile Zona de lucru- zona n care se afieaz documentul editat Barele de defilare- pentru deplasarea mai rapid n document; defilarea este posibil numai cu mouse-ul Bara cu unelte de desenare Linia de stare- afieaz informaii despre documentul la care se lucreaz Bara de programe Windows- este o component a sistemului Windows; afieaz aplicaiile active i ora curent; este utilizat pentru a comuta ntre diversele programe sau pentru a porni un nou program

159

Introducere n Informatic

Fig. 9.7. Ecranul aplicaiei Word 2000, varianta n limba englez

Fig. 9.8. Ecranul Word 2000, versiunea n limba romn B. Bara cu unelte standard Bara cu unelte conine butoane care pot fi selectate cu ajutorul mouse-ului pentru a realiza mai rapid aciuni de editare obinuite. Word afieaz chiar lng cursorul mouse-ului o mic fereastr ce conine o scurt descriere a funciei ndeplinite de butonul respectiv. C. Ieirea din Word pentru Windows Ieirea din program se poate face n urmtoarele moduri: folosind tastatura: ALT+ F4 folosind mouse-ul se face dublu clic pe butonul din stnga barei de titlu se apas butonul CLOSE afiat n dreapta barei de titlu (X) se selecteaz comanda EXIT din meniul FILE din bara de meniu a programului

160

Introducere n Informatic

9.2.2. Sistemul de asisten software on- line Comanda HELP Permite accesul n sistemul de asisten software al programului Word. La selectarea comenzii Help, se afieaz un submeniu ce conine urmtoarele comenzi: Microsoft Word help afieaz ecranul principal al sistemului de asisten software (fig 9.9) Show the Office Assistant/Hide the Office Assistant afieaz sau nltur de pe ecran asistentul soft Whats This? ofer informaii n context (Se poziioneaz mouse-ul pe un obiect de pe ecran i se face clic Office on the Web conecteaz calculatorul la un site Web unde se obin informaii despre Office Word Perfect help afieaz mesaje de asisten pentru utilizatorii familiarizai cu editorul de texte Word Perfect Detect and repair caut i repar erori n acest program. About Microsoft Word afieaz informaii despre programul Word

Fig. 9. 9. Meniul Help B. Ecranul Microsoft Word help Conine etichete care permit accesul n diferite zone ale sistemului de asisten software on-line. Aceste etichete sunt:

161

Introducere n Informatic

Fig. 9.9. Ecranul de asisten software - Contens- fiecare titlu (carte) din lista afiat definete o anumit seciune din materialul de asisten software; pentru a deschide o carte se selecteaz cartea respectiv i se apas butonul OK. - Answer wizard- permite obinerea de ajutor din partea sistemului de asisten punnd ntrebri formate cu propriile cuvinte - Index- conine o list ordonat alfabetic a subiectelor despre care se pot furniza informaii, facnd clic pe lista de interes i selectnd butonul Display. 9.2.3. Crearea unui document nou A. Introducerea textului Pe msur ce este tastat, textul apare pe ecran. Separarea logic n cuvinte se face apsnd bara de spaiu iar n paragrafe apsnd Enter. Pentru corectarea caracterelor greite se folosesc tastele Backspace sau Delete. B. Deplasarea n document Exist dou modaliti de deplasare a punctului (cursorului) de inserare: folosind mouse-ul sau tastatura. 1. cu ajutorul mouse-ului n sus/ jos cu o linie- clic pe una din sgeile sus/ jos de la capetele barei verticale de defilare n sus/ jos cu un ecran- clic pe bara de defilare vertical deasupra sau sub caseta de defilare n sus/ jos orict de mult- se trage caseta de defilare n sus/ jos n orice punct de pe ecran- clic pe ecran n punctul dorit 2. cu ajutorul tastaturii

162

Introducere n Informatic

la stnga/ dreapta cu un caracter- sgeat la stnga/ dreapta n sus/ jos cu o linie- sgeat sus/ jos la stnga/ dreapta cu un cuvnt: Ctrl+ sgeat stnga/ Ctrl+ sgeat dreapta n sus/ jos cu un paragraf: Ctrl+ sgeat sus/ jos la nceputul/ sfritul unei linii: Home/ End n sus/ jos cu un ecran: Page Up/ Page Down la nceputul/ sfritul ecranului: Ctrl+ Page Up/ Page Down la nceputul/ sfritul documentului: Ctrl+ Home/ Ctrl+ End

C. Selectarea unui bloc de text Se poate selecta textul folosind mouse-ul sau tastatura: a) cu mouse-ul: pentru un un bloc oarecare de text - se poziioneaz cursorul la nceputul blocului de text, se apas butonul din stnga i se deplaseaz mouse-ul pe blocul de text un cuvnt: - dublu clic deasupra cuvntului o propoziie: - tasta Ctrl i clic oriunde n propoziie o linie: - clic pe bara de selecie n dreptul liniei mai multe linii: - clic pe bara de selecie n dreptul liniilor un paragraf: - dublu clic pe bara de selecie n dreptul paragrafului tot documentul: - tasta Ctrl i clic oriunde n bara de selecie b) cu ajutorul tastaturii un bloc oarecare de text: se deplaseaz cursorul la nceputul blocului se apas Shift i se deplaseaz cursorul pn la sfritul blocului folosind tastele de deplasare tot documentul: Ctrl+ A Pentru a anula o selecie se face clic oriunde pe ecran. D. Utilizarea abloanelor Un ablon este un model sau un tipar utilizat de un document. ablonul poate conine texte ce rmn nemodificate, elemente de grafic, moduri de formatare. abloanele pot conine: stiluri de caractere, intrri de glosar, macrouri. Crearea unui document nou folosind un ablon se realizeaz astfel: - se selecteaz File New (fig. 9.11) - clic pe eticheta care corespunde numelui de document - clic pe pictograma asociat ablonului dorit - OK

163

Introducere n Informatic

Se poate utiliza un asistent ( Wizard). Un asistent const ntr-o serie de casete de dialog ntre care se trece cu urmtoarele comenzi: - clic pe Next pentru deplasarea la urmtoarea caset - Back pentru a modifica informaiile introduse (se revine la caseta precedent) - Finish pentru a crea documentul - Cancel pentru a abandona lucrul

Fig.9.11. Opiunile New Deplasarea n casete de dialog. Casetele de dialog reprezint calea prin care un program solicit informaii suplimentare. Orice caset de dialog conine unul sau mai multe dintre urmtoarele elemente: - etichete (tabs) - afiarea de pagini suplimentare cu opiuni selectabile - casete cu liste (list boxes)- afieaz alegerile posibile - casete cu liste derulante (drop-down lists) - similare casetelor cu liste, dar numai un singur element al listei este afiat iniial - casete de text (text boxes)- permit activarea sau dezactivarea individual a unei opiuni - butoane de opiune (option button) sunt similare casetelor de opiune, dar butoanele apar n grupuri, din care numai unul singur poate fi activ la un moment dat (butoane radio) - butoane de comand (command buttons) permit executarea unei aciuni. 9.2.4. Salvarea documentelor Salvarea documentelor noi (prima salvare) se face astfel:

164

Introducere n Informatic

- se selecteaz comanda File Save; se deschide fereastra de dialog Save As - n caseta File Name se introduce numele documentului, apoi se selecteaz butonul Save Salvarea unui document existent: - comanda Save din meniul File - se apas butonul Save din bara cu unelte standard Schimbarea numelui unui document: - se selecteaz comanda File Save As - se schimb numele fiierului - se selecteaz OK Schimbarea informaiilor de rezumat - se selecteaz File Properties, se fac modificrile dorite OK. 9.2.5. Tiprirea documentelor 1. Tiprirea rapid Imprimanta trebuie s fie instalat i selectat. Se procedeaz astfel: - se selecteaz comanda File Print sau se apas Ctrl + P; se alege OK - pentru a tipri o copie a ntregului document, se face clic pe butonul Print din caseta de unelte standard 2. Tiprirea unei pri a documentului se face astfel: - se selecteaz comanda File Print sau se apas CTR + P - n zona Page Range, se selecteaz opiunea Current page pentru a tipri pagina n care se afl cursorul text - se selecteaz opiunea Pages pentru a tipri mai multe pagini (i se indic limitele de tiprire) - se selecteaz OK. Caseta de dialog Print conine: - Print What -pentru a tipri informaii despre un document - Print- pentru a tipri toate paginile, numai cele pare sau numai cele impare - Number of copies- pentru a tipri mai multe copii ale documentului - Options pentru a stabili ordinea sau tipul de tiprire

165

Introducere n Informatic

Fig. 9.12. Cutia de dialog Print Folosirea opiunilor de tiprire - selectai File Print sau apsai Ctrl + P - selectai Options - n zona Printing Options, selectai una din opiunile urmtoare: - Draft Output- produce o tiprire a documentului n ciorn care este mai rapid - Revers Print Order- tiprete paginile n ordine invers, ncepnd cu ultima pagin - Update Fields reactualizeaz automat cmpurile de date ale documentului nainte de tiprire - selectai OK- se revine n caseta de dialog Print Setarea paginii Pentru a schimba dimensiunile i orientarea paginii, procedai astfel: - se selecteaz File Page Setup - se face clic pe opiunea Page Size - deschidei lista Paper Size - selectai mrimea dorit a paginii - dac selectai Custom Size, folosii casetele Hight si Width pentru a indica dimensiunile paginii - orientation- selectai orientarea paginii Portrait sau Landscape - selectai OK

166

Introducere n Informatic

Fig.9.13. Cutia de dialog Page setup

Fig. 9.14. Stabilirea dimensiunilor paginii 9.2.6. Mutarea si copierea textului Exist mai multe moduri de a realiza copierea unui bloc de text: - copierea prin intermediul memoriei temporare (clipboard): se selecteaz textul; se selecteaz comanda Edit Copy (CTRL + C),se mut cursorul n noua poziie n text; se selecteaz Edit Paste sau butonul Paste din bara cu unelte standard - copierea cu ajutorul mouse-ului: se selecteaz textul, se mut cursorul n poziia dorit, se apas Ctrl + Shift i se apas butonul din dreapta al mouse-ului - copierea textului abia introdus: introducei textul ntr-una din poziiile dorite n document; mutai cursorul ntr-o alt poziie n care este nevoie de acelai text; selectai Edit Repeat Typing sau F4. 9.2.7. Formatarea documentului Formatarea se refer la schimbrile care sunt fcute n aspectul documentului. Formatarea este o parte important n editarea documentului. Un document atractiv i bine formatat are un impact mai mare i este mai clar dect unul ru formatat. Formatarea are mai multe paliere: la nivel de

167

Introducere n Informatic

caractere, la nivel de paragrafe, la scara ntregului document. Vom prezenta pe scurt cele mai importante elemente de formatare. A. Formarea caracterelor Se refer la atributele care se pot aplica asupra caracterelor individuale dintr-un document. Setarea corpului de litera (font), mrimea de scriere, sublinierea, scrierea cu cursive (italic) sau aldine (bold) sunt exemple de comenzi de formatare ale caracterelor. Schimbarea corpului de liter pentru un text existent se face astfel: selectai textul, selectai Font Name din bara de formatare (folosind tastatura- Ctrl + Shift + F) i apoi apsai tasta sgeat n jos; selectai din list corpul de liter dorit, apsai Enter. Pentru a schimba mrimea de scriere folosind mouse-ul, deschidei lista Font Size din bara de formatare; folosind tastatura, apsai Ctrl+Shift+P i apoi sgeat n jos. Aldine, sublinieri, cursive: butoane de setare: butoane a cror selectare activeaz atributul corespunzator dac era activ sau l dezactiveaz dac era activ.

B. Setarea marginilor i a spaierii liniilor Afiarea riglei: selectai View Toolbars. Margini: marginile din stnga i cea din dreapta sunt distanele de la text pn la latura din stnga respectiv cea din dreapta paginii. Setarea marginilor din stnga i dreapta paginii sau a marginilor de sus i de jos cu ajutorul unei casete de dialog se face astfel: mutai cursorul n poziia dorit selectai File Page Setup, apoi clic pe sgeat n sus sau n jos pentru a crete sau a descrete mrimea marginii corespunztoare deschidei caseta Apply to i selectai domeniul Whole Document sau This Point Foward (ncepnd din poziia curent); OK. Valorile setate pentru marginile de sus/jos ale paginii nu afecteaz poziiile antetului i subsolului. Schimbarea distanei dintre liniile de text se face astfel: selectai Format Paragraph; clic pe opiunea Indents and Spacing deschidei lista Line Spacing: 1. Exactly- spaiul dintre linii va fi exact valoarea pe care o introducei n caseta At

168

Introducere n Informatic

2. At Least- spaiul dintre linii va fi cel puin valoarea pe care o introducei n caseta At 3. Multiply- schimb spaierea n funcie de valoarea pe care o introducei n caseta At

Fig. 9.15. Indentarea i spaierea liniilor de text

Fig. 9.16. Controlul grupurilor de linii Mutarea si tergerea propriilor poziii de scriere;

169

Introducere n Informatic

deplasai cursorul deasupra simbolului afiat pe rigl n dreptul poziiei de scriere apsai butonul din stnga al mouse-ului tragei poziia de scriere n poziia dorit eliberai butonul mouse-ului 9.2.8. Alinierea textului

Alinierea paragrafelor. Alinierea se aplic asupra unei singure linii sau a mai unor poriuni mici de text. Marginea unui paragraf este distana dintre marginea textului de paragraf i marginile paginii. Setarea marginilor de paragraf cu ajutorul riglei: pentru a schimba marginea din stnga a primei linii din paragraf, tragei simbolul First Line Indent n poziia dorit pentru a schimba marginea din stnga unui paragraf, mai puin prima linie, tragei simbolul Other Lines Indent n poziia dorit pentru a modifica marginile din stnga ale tuturor liniilor dintr-un paragraf, tragei simbolul All Lines Indent n poziia dorit pentru a modifica marginea din dreapta a unui paragraf, tragei simbolul Right Indent n poziia dorit. Observaii: Aliniere rapid: facei clic pe unul din butoanele Increase Indent sau Decrease Indent afiate pe bara de formatare a textului Afiarea barei de formatare: selectai View Toolbars, apoi opiunea Formatting

Aranjarea textului Left justification- aliniaz marginea din stnga a liniilor de text Right justification- aliniaz marginea din dreapta a liniilor de text Full justification- aliniaz ambele margini Center justification- centreaz liniile de text pe limea paginii Schimbarea alinierii Dac schimbai alinierea textului fr a fi selectat anterior nici un paragraf, atunci noua aliniere se va aplica numai asupra textului pe care l vei introduce n continuare. 9.2.9. Numerotarea paginilor. Crearea antetelor i a cartuelor de subsol

170

Introducere n Informatic

a) Numerotarea paginilor selectai Insert Page Numbers deschidei lista Position i selectai poziia dorit deschidei lista Alignment i selectai una dintre opiunile: Left, Center, Right selectai OK

Fig. 9.17. Caseta Page Numbers b) Antet i subsol Antetul este plasat n partea de sus a paginii; subsolul este plasat n partea de jos a paginii. Adugarea sau editarea unui antet/subsol: selectai View Header and Footer; facei clic pe butonul Switch de pe aceast bar pentru a comuta antetul i subsolul asociate paginii curente; introducei textul antetului/ subsolului. Din bara cu unelte Header and Footer, putei fixa data, ora, numrul paginii (Data, Time, Page number). Facei clic pe unul din butoanele Show Next/ Show Previous pentru a comuta ntre diferitele seciuni ale antetului/subsolului. Facei clic pe butonul Close pentru a reveni n document. Crearea de anteturi/ subsoluri diferite pentru pagini diferite Word poate afia acelai antet/ subsol pe toate paginile documentului sau antet/subsol diferit pe pagini pare i impare. Se procedeaz astfel: selectai View Header and Footer, facei clic pe butonul Page Setup Layout pentru a se afia opiunile referitoare la aspectul paginii. Activa i opiunea Different Odd and Even/ Different First Page; selectai Ok pentru a nchide caseta Page Setup. c) Note de subsol i note de final Inserarea unei note de subsol/de final: deplasai cursorul n text n poziia dorit n care vrei s fie introdus simbolul asociat unei note de subsol/de final; selectai Insert Footnote; se face clic pe opiunea Autonym pentru evidenierea notelor; Custom Mark pentru utilizarea unui simbol pentru marcare; Symbol pentru selectarea simbolului dorit. Mutarea i tergerea notelor: selectai Edit Cut sau apsai Ctrl+ X; butonul Cut din bara cu unelte standard; mutai cursorul n noua poziie;

171

Introducere n Informatic

selectai Edit Paste sau apsai Ctrl+V sau clic pe butonul Paste din bara cu unelte standard.

Fig. 9.18. Caseta de dialog Footnote and Endnote 9.2.10. Caractere speciale i simboluri Simbolurile i caracterele speciale nu apar in setului standard de caractere. Exist mult mai multe simboluri dect caractere speciale. Inserarea unui simbol n document: selectai Insert Symbols; cutai simbolul dorit; facei clic pe butonul Close pentru a nchide caseta de dialog dup inserarea unui simbol. Inserarea unui caracter special n document: selectai Insert Symbols; facei clic pe eticheta Special Characters; parcurgei lista n cutarea caracterului dorit; alegei butonul Insert pentru a insera caracterul special evideniat. Facei clic pe butonul Cancel pentru a nchide caseta fr a insera vre-un caracter special.

172

Introducere n Informatic

Fig. 9.19. Caseta Insert Symbols 9.2.11. Liste numerotate sau marcate Constituie unelte de formatare care se pot folosi pentru prezentarea informaiilor dintr-un document. a) Crearea unei liste numerotate sau marcate: - selectai paragrafele care vor fi incluse n list - selectai Format Bullet and Numbering - facei clic pe Bulleted (liste marcate) sau Numbering (liste numerotate) b) nlturarea numerelor/ marcajelor dintr- o list - selectai paragrafele care vor fi eliminate - selectai Format Bullet and Numbering - selectai Remove c) Adugarea de noi elemente ntr-o list: - deplasai cursorul text n poziia dorit din list - apsai Enter pentru a ncepe un nou paragraf - introducei noul text

173

Introducere n Informatic

Fig. 9.20. Caseta de dialog pentru crearea listelor - facei clic pe Decrease Indent/ Increase Indent de pe bara cu unelte standard pentru a schimba nivelul elementului respectiv - repetai secvena de mai sus dac este nevoie 9.2.12. Tabele a) Inserarea unui tabel mutai cursorul text n locul unde dori i un tabel selectai Table, Insert Table. Va fi afiat dialogul de introducere a tabelelor noi. n csua Number of columns i Number of Rows introducei numrul de coloane i de linii al viitorului tabel. n csua Column Width selectai limea coloanelor tabelului; selectai Auto pentru ca limea s fie automat calculat pentru ca tabelul s aib limea paginii selectai OK Folosirea barei cu unelte. Pentru a insera un tabel, selectai butonul Table de pe bara cu unelte standard i executa i un clic deasupra numrului dorit de rnduri i coloane. b) Deplasarea in tabel Apsai Pentru a ajunge la TAB urmtoarea celul a tabelului SHIFT+ TAB celula anterioar a tabelului ALT+ HOME prima celul a rndului curent ALT+ PGUP celula din vrful coloanei curente ALT+ END ultima celul a rndului curent ALT+ PGDN ultima celul de pe coloana curent

174

Introducere n Informatic

Fig. 9.21. Meniul Table c) tergerea i inserarea de celule, rnduri i coloane Putei terge celule individuale, nlturnd coninutul lor i lsnd celula goal. Selectare rapid! Pentru a selecta o celul, apsai pe butonul mouse-ului n marginea stnga a celulei, ntre marginea textului i linia ce delimiteaz celula. Cursorul mouse-ului se schimb deasupra acestei zone ntr-o sgeat neagr. Pentru a terge o celul: selectai celula; apsai Del. Pentru a terge un rnd sau o coloan: mutai cursorul n orice celul de pe acel rnd sau de pe acea coloan selectai Table Delete Cells selectai Delete Entire Row pentru a terge ntregul rnd, sau Delete Entire Column pentru a terge ntreaga coloan selectai OK Pentru a insera un rnd sau o coloan: mutai cursorul text ntr-o celul la dreapta sau dedesubtul locului unde dori i s insera i noul rnd sau noua coloan selectai Table Select Row pentru a insera un rnd sau Table Select Column pentru a insera o coloan selectai Table Insert Column pentru a insera o coloan goal la stnga celei selectate sau Table Insert Row pentru a insera un rnd gol deasupra celui selectat Comenzile se schimb! Comenzile din meniul Table se schimb n funcie de circumstane. Dac a i selectat o coloan, este afiat comanda Insert Columns i nu este afiat comanda Insert Rows. d) Mutarea i copierea coloanelor sau liniilor

175

Introducere n Informatic

selectai linia sau coloana pentru a copia, selectai CTRL+ C sau clic pe butonul Copy mutai cursorul n noua poziie dorit apsai CTRL+ V sau clic pe butonul Paste e) Formatarea automat a tabelului mutai cursorul text oriunde n interiorul tabelului selectai Table AutoFormat n zona Preview Putei vedea cum arat un tabel de tipul selectat selectai sau deselectai opiunile dup dorin; selectai OK 9.2.13. Lucrul cu documente multiple

Mutarea i copierea textului ntre documente activai documentul care conine textul pe care dorii s-l mutai sau s-l copiai apsai CTRL+ X sau Edit Cut pentru a muta textul apsai CTRL+ C sau Edit Copy pentru a copia textul deplasai cursorul de inserie n noua poziie apsai CTRL+ V, selectai Edit Paste sau executai clic pe butonul Paste din bara cu unelte standard Afiarea simultan a dou zone dintr-un document selectai Window Split folosii mouse-ul sau tastatura, tasta sgeat n sus sau n jos pentru a muta linia n poziia dorit facei clic cu mouse-ul sau apsai Enter selectai Window Remove Split pentru a renuna la mprirea ferestrei Salvarea documentelor multiple: File Save sau File Save As. Pentru a salva toate documentele deschise cu o singur comand , selectai File Save All.

9.2.14. Scrierea n coloane Pentru scrierea pe coloane se deschide meniul Format i se alege opiunea Columns. Se va deschide o cutie de dialog (fig. 9.22) n care se precizeaz numrul de coloane i modul de aplicare a scrierii pe coloane (ntreg documentul, de la acest punct mai departe etc.).

176

Introducere n Informatic

Fig. 9.22. Caseta de dialog Columns 9.2.15. Inserarea imaginilor Se deschide meniul Insert i se alege opiunea Image. Se deschide un submeniu n care se precizeaz sursa i tipul de imagine care va fi inserat. Figura 9.23 ilustreaz caseta Insert ClipArt.

Fig. 9.23. Caseta Insert ClipArt

9.3. Aplicaii practice n WORD


9.3.1. Mutarea i copierea textului

177

Introducere n Informatic

Se poate muta sau copia orice element (text sau ilustraie) ntr-un document. Pentru aceasta se utilizeaz comenzile Cut (decupare), Copy (copiere) i Paste (inserare). Aceste comenzi utilizeaz memoria Clipboard a Sistemului de Operare Windows. Comanda Cut copiaz obiectul selectat n Clipboard i terge originalul. Comanda Copy copiaz obiectul selectat n Clipboard i pstreaz originalul. Comanda Paste copiaz coninutul memoriei Clipboard la poziia cursorului. Dac exist un obiect selectat se va copia peste acesta.

Fig. 9.24. Executarea comenzilor Cut, Copy i Paste. Pentru a muta sau copia un text, acesta trebuie selectat (cu tastatura sau cu mouse-ul). Pentru mutare se execut comanda Cut, se mut cursorul la noua poziie i se execut comanda Paste. Pentru copiere se execut comanda Copy, se mut cursorul la noua poziie i se execut comanda Paste.
Copiere = ( CUT + PASTE ) Mutare = ( COPY + PASTE )

9.3.2. Formatarea textului Chiar dac unele figuri i explicaii se vor repeta, consider c repetarea va aduce un plus n fixarea cunotinelor dobndite. Formatarea textului presupune mai multe operaii printre care: selectarea fonturilor i a tipodimensiunilor, alinierea, stabilirea formatului hrtiei, a marginilor, scrierea pe coloane, stabilirea antetului i a notei de subsol, creare liste etc. A. Fonturi Un font este o colecie de litere, numere, simboluri i semne de punctuaie care au un design particular. Fonturile i dimensiunile acestora, care pot fi utilizate depind de imprimanta sau imprimantele instalate i de fonturile instalate pe calculator. Pentru modificarea fonturilor unui text se selecteaz textul apoi se parcurge calea: Format -> Font ... . Astfel se deschide fereastra Font, care

178

Introducere n Informatic

permite selectarea tipului de Font, a dimensiunii (Size) i diferite alte opiuni legate de fonturi.

Fig. 9. 15. Comanda de deschidere a ferestrei Font.

Fig. 9. 26. Fereastra Font. n fereastra font, opiunile superscrip i subscript permit scrierea exponentului (indicele superior) i a indicelui inferior. B. Alinierea textului Pentru aliniere se selecteaz textul, i se parcurge calea: Format -> Paragraph ... Astfel se deschide fereastra Paragraph. Se alege opiunea Alignment. Alinierea poate fi Left, Centered, Right sau Justified.

Fig. 9. 27. Comanda de deschidere a ferestrei Paragraph.

179

Introducere n Informatic

Fig. 9. 28. Fereastra Paragraph. Subfereastra Indentation permite crearea unei margini stnga i a unei margini dreapta a paragrafului, n raport cu celelalte paragrafe. Aspectul paragrafului se vede n Preview. Subfereastra Spacing permite introducerea unui spaiu naintea paragrafului i dup, i permite de asemenea spaierea textului la un rnd, la un rnd jumtate, dou, etc.

Fig. 9. 29. Opiunea Alignment din fereastra Paragraph. C. Stabilirea formatului hrtiei Pentru stabilirea formatului hrtiei se parcurge calea: File -> Page Setup ... Astfel se deschide fereastra Page Setup. Se deschide pagina Paper Size. Se selecteaz opiunile Paper size i Orientation.

180

Introducere n Informatic

Fig. 9. 30. Comanda de deschidere a ferestrei Page Setup.

Fig. 9. 31. Fereastra Page Setup - pagina Paper size. D. Stabilirea marginilor Din fereastra Page Setup, se alege pagina Margins. Se pot selecta marginile Top, Bottom, Left i Right. De asemenea se poate selecta dimensiunea antetului i a notei de subsol. E. Scrierea pe coloane Pentru scrierea pe mai multe coloane, selectm textul dorit, apoi deschidem fereastra Column astfel: Format -> Column ... . n fereastra Column se selecteaz opiunea Number of Column.

181

Introducere n Informatic

Fig. 9. 32. Fereastra Page Setup - pagina Margins.

Fig. 9. 33. Comanda de deschidere a ferestrei Column.

Fig. 9. 34. Fereatra Column. F. Numerotarea paginilor Pentru numerotarea paginilor se deschide fereastra Page Number ... astfel: Insert -> Page Numbers ... . n fereastra Page Numbers ..., se

182

Introducere n Informatic

selecteaz opiunile: Position (pentru stabilirea numerotrii sus sau jos n pagin) i Alignment (pentru alinierea numerotrii Left, Center sau Right.

Fig. 9. 35. Comanda de deschidere a ferestrei Page Numbers ...

Fig. 9. 36. Fereastra Page Number ... G. Creare antet i not de subsol Pentru creare antet i not de subsol se parcurge urmtoarea cale: View -> Header and Footer. Dup deschiderea ferestrei se pot completa att antetul ct i nota de subsol.

Fig. 9. 37. Deschiderea ferestrei Header and Footer.

Fig. 9. 38. Fereastra Header and Footer.

183

Introducere n Informatic

9.3.3. Aplicaie practic S se editeze un document Microsoft Word, de dou pagini, utilizndu-se trei tipuri de fonturi (Times New Roman, Arial i Curier), diferite dimensiuni (size) pentru titlu, autor, text normal etc. S se utilizeze scrierea pe dou coloane, cel puin dou tipuri de alinieri, formatul hrtiei A4, Portrait. Numerotarea paginilor s fie fcut jos, n mijloc. A. Inserare simboluri Uneori este necesar s utilizm simboluri care nu se afl pe tastatur: diacritice pentru diferite limbi strine, simboluri matematice etc. n acest caz procedm astfel: - Poziionm cursorul n poziia unde dorim s inserm un simbol; - Din meniu alegem opiunea Insert -> Symbol ... - Se va deschide fereastra Symbol:

Fig. 9. 39. Fereastra Symbol. n fereastra Symbol, din lista Font se poate alege setul de fonturi dorit (inclusiv simboluri matematice). Se alege simbolul dorit (care va aprea mrit n fereastr, n figura noastr este selectat simbolul ). Se apas butonul Insert i simbolul se va insera la poziia cursorului n text. Cu ajutorul butonului Shortcut Key ..., se poate ataa o combinaie de taste pentru simbolul respectiv. Acest lucru este util dac anumite simboluri se repet prea des, atunci cu ajutorul cu ajutorul combinaiei selectate se poate insera simbolul anterior selectat, fr a mai deschide fereastra Symbol. Aceast facilitate poate fi utilizat pentru diacritice strine (limba francez: , , , , , , i limba german: , etc.). Totui pentru caracterele specifice unei anumite limbi, soluia artat nu este cea mai simpl. Exist posibilitatea de a introduce, configura o tastatur pentru o

184

Introducere n Informatic

anumit limb din sistemul de operare. Configurarea sistemului de operare depete cadrul acestui material. Diacriticele pentru limba romn, vor fi selectate din sistemul de operare. Dac sistemul de operare a fost configurat corespunztor, atunci n dreapta jos a ecranului exist un buton albastru din care se pot alege caratere de scriere pentru limba englez sau pentru limba romn. B. Inserare marcatori i numerotare Word permite inserare marcatori i numerotare pentru a scoate n eviden paragrafe care fac enumerarea unei liste. Pentru a insera marcatori de liste de paragrafe sau numerotarea paragrafelor se alege din meniu urmtoarea opiune Format -> Bullets and Numbering ... . Se deschide fereastra Bullets and Numbering. n aceast fereastr se alege marcatorul dorit i se apas butonul OK. Dup introducerea unui paragraf, la apsarea tastei Enter, se creaz automat un nou nceput de paragraf cu un nou marcator. Dac se apas tasta Enter fr s fie introdus text de paragraf se ntrerupe lista de marcatori.

Fig. 9. 40. Fereastra Bullets and Numbering. C. Tabele Pentru inserarea unui tabel se poziioneaz cursorul la poziia dorit i apoi se alege din meniu opiunea Table -> Insert -> Table.... Se deschide fereastra Insert Table, care permite crearea unui tabel. Din csuele Number of columns i Number of rows se poate alege numrul de coloane i de rnduri pe care l va avea viitorul tabel.

185

Introducere n Informatic

Fig. 9. 41. Fereastra Insert Table. Pentru modificarea liniaturii tabelului se alege din meniu opiunea Table -> Table Properties ....

Fig. 9. 42. Fereastra Table Properties.

186

Introducere n Informatic

Din pagina Table, se apas butonul Borders and Shading .... Se deschide fereastra Borders and Shading, care permite modificarea liniaturii tabelului.

Fig. 9. 43. Fereastra Borders and Shading. Pentru a se uni dou sau mai multe celule, se selecteaz celulele corespunztoare apoi se alege din meniu opiunea Table -> Merge Cells.

Fig. 9. 44. Unire celule.

Fig. 9. 45. Scindare celule.

187

Introducere n Informatic

Pentru a scinda celule, se selecteaz celula dorit, apoi se alege din meniu opiunea Table -> Split Cells .... Se deschide fereastra Split Cells, care permite stabilirea numrului de linii i de coloane n care se dorete scindarea celulei.

Fig. 9. 46. Fereastra Split Cells. D. Microsoft Equation 3.0 Dac se dorete editarea unei ecuaii se procedeaz astfel: - Se poziioneaz cursorul la poziia unde se dorete inserarea ecuaiei; - Se alege din meniu opiunea: Insert -> Object .... Se va deschide fereastra Object:

Fig. 9. 47. Fereastra Object.

188

Introducere n Informatic

- Din lista Object type se alege Microsoft Equation 3.0 i se apas butonul OK. Se va deschide meniul de editare ecuaii i o fereastr de editare:

Fig. 9. 48. Meniul de editare ecuaii. Meniul de editare ecuaii conine butoane, care la apsare, fiecare deschide o list de opiuni utile pentru editarea ecuaiilor. Pentru introducerea de spaii n formule trebuie apsat combinaia Ctrl+SpaceBar. Dup editarea ecuaiei se efectueaz click cu mouse-ul n afara ferestrei de editare. Efectul este nchiderea ferestrei de editare. Dac dorim modificarea dimensiunii formulei, se selecteaz fereastra de editare cu un click. Se aga colul din dreapta jos al casetei care conine formula i efectum o operaie Drag. Dac se execut operaia pe o latur, efectul este deformarea formulei. Drag (a trage) - n mediile cu interfee grafice cu utilizatorul, a muta o imagine sau o fereastr dintr-un loc al ecranului n altul prin "apucarea" ei i tragerea ctre noua poziie cu ajutorul mouse-ului. Se plaseaz indicatorul mouse-ului pe obiectivul vizat, apoi se apas butonul mouse-ului i se ine aa pn cnd mouse-ul ajunge n noua poziie. Dac dorim plasarea formulei n centrul liniei, se selecteaz formula i se selcteaz Format -> Paragraph -> Alignment -> Justified. Dac dorim deplasarea formulei spre dreapta (n mijlocul paginii), efectum un click cu mouse-ul n dreapta formulei (n afara acesteia). Cursorul de inserare al textului se va poziiona n dreapta formulei. Apsm o singur dat pe tasta sgeat stnga. Cursorul se va poziiona n stnga formulei. Cu ajutorul tastei Tab sau SpaceBar se vor insera caractere n stnga formulei, care o vor mpinge spre dreapta. Dac se dorete corectarea formulei se ve efectua un dublu click asupra formulei. n urma acestei aciuni se redeschide meniul de editare ecuaii. E. Clip Art Clip Art permite adugarea de miniaturi la un document. Pentru adugarea unei miniaturi, se poziioneaz cursorul la poziia din text unde se

189

Introducere n Informatic

dorete inserarea miniaturii, apoi se alege din meniu opiunea: Insert -> Picture -> Clip Art .... Se deschide fereastra Insert ClipArt, care conine categorii de miniaturi. Se alege o categorie i apoi din categoria respectiv se poate selecta o miniatur, care se insereaz n document.

Fig. 9. 49. Fereastra Insert ClipArt. F. Auto Shapes Produsul Microsoft Word are un puternic instrument Auto Shape care permite crearea de forme automate (scheme logice, organigrame, etc.). Pentru aceasta din meniu se selecteaz opiunea Insert -> Picture -> AutoShapes. Se deschide bara de instrumente AutoShapes, care permite alegerea formelor dorite pentru inserarea n text. Aceste forme pot fi redimensionate i mutate dup dorin folosind aceleai procedee ca i n cazul formulelor.

Fig. 9. 50. Bara de instrumente AutoShapes. G. Word Art Word Art permite introducerea cuvintelor scrise artistic n text. Pentru aceasta se alege din meniu opiunea Insert -> Picture -> WordArt .... Se deschide fereastra WordArt Gallery.

190

Introducere n Informatic

Fig. 9. 51. Fereastra WordArt Gallery. 9.3.4. Aplicaie practic 1. S se insereze n text soluia ecuaiei de gradul 2:
x 1,2 = b b 2 4 a c 2 a

Ecuaia 1. Soluia ecuaiei de gradul 2. 2. S se ntocmeasc urmtoarea schem logic: 3. S se ceeze i s se completeze urmtorul tabel: Nr. crt. 1 Nume Prenume 3 Adres Strad 5

Nume 2

Localitate 4

Numr 6

Tabelul 9.1. Exemplu de tabel Word.

191

Introducere n Informatic

START

Citete A NU Dac A > 0 DA Tiprete A

STOP
Fig. 9. 52. Exemplu de schem logic. A. Creare legend figur, ecuaie sau tabel Legenda este informaia care se adaug la o figur, ecuaie sau un tabel. Pentru a insera o legend n text se alege din meniu urmtoarea opiune Insert -> Caption .... Aceast aciune va duce la deschiderea ferestrei Caption.

Fig. 9. 53. Fereastra Caption.

192

Introducere n Informatic

Din lista Label se alege tipul legendei (pentru figur, ecuaie sau tabel). Apoi se apas butonul OK. Se genereaz automat legenda dorit. Trebuie numai s completm textul legendei. Word ine evidena numerelor legendelor, separat pentru figuri, pentru ecuaii i pentru tabele. Dac se insereaz o legend, automat numerele celor care o urmeaz este incrementat cu unu. Dac se terge o legend numerele celor care o urmeaz se decrementeaz cu unu. La sfrit se poate genera o list de figuri, list de ecuaii i list de tabele, Word afind i paginile la care se gsesc. B. Inserare list de figuri, de ecuaii i de tabele Pentru inserarea unei liste de figuri, ecuaii sau tabele, se poziioneaz cursorul unde se dorete crearea listei, se alege din meniu opiunea Insert -> Index and Tables ... . Se deschide fereastra Index and Tables.

Fig. 9. 54. Fereastra Index and Tables. Se selecteaz pagina Table of Figures. Din lista Caption label, se alege tipul legendei (pentru figur, pentru ecuaie sau pentru tabel). Apoi se apas butonul OK. Dac a mai fost generat lista respectiv apare ntrebarea dac se dorete suprascriere. Aceast situaie apare destul de des, deoarece n cazul apariiei de noi legende, trebuie actualizat i lista corespunztoare. Word nu face singur aceast actualizare. Trebuie generat din nou lista i n cazul apariiei ntrebrii dac dorim suprascriere, rspunsul este DA.

193

Introducere n Informatic

C. Titluri de capitole Este de dorit ca titlurile de capitole s nu fie formatate individual. Pentru fiecare nivel de titlu trebuie creat un stil (tip de font, alinierea paragrafului etc.). Dac se lucreaz n acest mod mod, modificarea stilului presupune modificarea tuturor titlurilor de nivelul respectiv. Pentru ataarea unui nivel de titlu unui anumit text, se selecteaz textul dorit, apoi se alege din meniu opiunea urmtoare Format -> Style .... Se deschide fereastra Style.

Fig. 9. 55. Fereastra Style. Din lista Styles: se alege Heading 1 sau alt nivel. La toate titlurile trebuie s-i atam un nivel de stil Heading. Titlurile principale vor fi Heading 1. Titlurile de subcapitole vor fi Heading 2, etc. D. Generare cuprins Word ine evidena tuturor titlurilor i se poate genera un cuprins cu ajutorul lor. Pentru generarea cuprinsului, poziionm cursorul n locul n care dorim s generm cuprinsul, apoi alegem din meniu urmtoarea opiune Insert -> Index and Tables .... Se deschide fereastra Index and Tables. Se selectez pagina Table of Contents.

194

Introducere n Informatic

Fig. 9. 56. Pagina Table of Contents. Din lista Show levels se poate alege nivelul de capitol care s fie generat ultimul n cuprins. Se apas butonul OK. E. Hiperlegturi Hiperlegturile sunt o facilitate deosebit a documentelor electronice. Hiperlegturile permit saltul la o alt zon de informaii, i cnd se dorete, ne putem ntoarce la locul de unde s-a efectuat saltul. Se pot efectua mai multe salturi, Word-ul tinnd evidena lor, i la dorin, se poate face revenire. De la un text, figur, tabel sau alt obiect inserat n text se poate face o legtur. Legtura se poate face la acelai document la un marcaj, la nceputul unui alt document, la un marcaj ntr-un alt document sau la o adres de Internet. Dac se dorete saltul la un anumit marcaj este necesar s definim marcajul respectiv. Pentru aceasta este necesar s poziionm cursorul n locul n care dorim s definim un marcaj, apoi din meniu alegem opiunea Insert -> Bookmark .... Se deschide fereastra Bookmark. n zona Bookmark name: se introduce numele dorit pentru marcaj i se apas butonul Add. Numele marcajului este inserat n lista de nume i fereastra se nchide. Pentru inserarea unei hiperlegturi se selecteaz obiectul cruia dorim s-i atam legtura (de exemplu un text). Apoi se alege din meniu

195

Introducere n Informatic

urmtoarea opiune Insert -> Hyperlink .... Se deschide fereastra Insert Hyperlink.

Fig. 9. 57. Fereastra Bookmark.

Fig. 9. 58. Fereastra Insert Hyperlink. n fereastra Insert Hyperlink: - dac se dorete o hiperlegtur la un marcaj n cadrul aceluiai document se apas butonul Bookmark ...; - dac se dorete o hiperlegtur la un alt document se apas butonul File ...;

196

Introducere n Informatic

- iar dac se dorete o hiperlegtura la o adres de Internet se apas butonul Web Page ....

197