Sunteți pe pagina 1din 15

Lucrare de laborator nr.

MODELAREA CORPURILOR n CATIA V5, modelarea unei piese (aplicaia Part Design) ncepe cu deschiderea unui fiier nou cu extensia .CATPart; pentru aceasta se folosete fie succesiunea de comenzi File > New, fie se acioneaz direct iconul New . Rezultatul este afiarea pe ecran a unei ferestre de dialog care permite alegerea tipului de fiier dorit (opiunea List of Types), i a iconurilor corespunztoare comenzilor de creare i editare a entitilor (fig.1). Pentru exemplificarea modului n care se poate modela o pies utiliznd CATIA V5, n continuare se prezint procedurile de lucru pentru unele dintre cele mai des folosite opiuni de modelare: Pad, Draft, Edge Fillet, Mirror, Pocket, Shell, Shaft, Fig.1. Meniul cu comenzile Groove, Hole, Stiffener, Thickness, de lucru (workbench toolbar). Sew Surface i User Pattern. Opiuni de construire a modelelor tridimensionale Opiunea Pad Crearea unui bosaj n planul XY se face parcurgnd urmtoarele etape: - Se alege iconul Pad; - n fereastra Pad Definition (fig.2) se introduc valorile dorite (de exemplu, lungime de 20 mm), bosajul fiind prezentat utilizatorului nainte de a fi creat (opiunea Preview); - Se alege OK, n acest caz extrudarea fcndu-se perpendicular pe planul ales (XY, n cazul prezentat). Extrudarea se

poate face i dup o anumit direcie fa de vertical, n acest scop fiind necesar detalierea ferestrei din figura 2 (opiunea More) i alegerea opiunii corespunztoare. Modelul bosajului creat este prezentat n figura 3, sistemul adugnd automat numele entiti la arborele de comenzi aflat n partea stng a ecranului de lucru.

Fig. 2. Dialogul de creare a unui bosaj, Pad Definition. Opiunea Draft

Fig. 3. Modelul tridimensional al unui bosaj.

Pentru nclinarea unei fee, procedura care trebuie urmat este urmtoarea: - Se alege iconul Draft, ceea ce determin apariia pe ecran a dialogului Draft Definition (fig.4).

Fig. 4. Dialogul Draft Definition.

Fig. 5. Selectarea uneia dintre fete.

- Se alege o fa a piesei (fig. 5) prin selectarea acesteia de pe ecranul grafic, sistemul detectnd toate feele care vor fi nclinate cu valoarea indicat; - Se opteaz pentru varianta Selection by neutral face, elementul neutru selectat fiind faa de sus a piesei; o - Se introduce valoarea de 9 n cmpul corespunztor Angle; - Se alege OK, rezultatul operaiei este prezentat n figura 6.

Fig. 6. Aplicarea comenzii Draft. Optiunea Edge Fillet Racordarea unei muchii se efectueaz astfel: - Se alege comanda Edge Fillet, iar n fereastra de dialog Edge Fillet Definition se introduc parametri dorii: raza de racordare de 5 mm, propagare tangenial, etc. (fig.7); - Se selecteaz muchia care se dorete rotunjit; - Se alege OK, piesa obinut n urma racordrii uneia dintre muchii fiind prezentat n figura 8.

Fig. 7. Dialogul de creare a racordrilor.

Fig. 8. Rezultatul aplicrii opiunii Edge Fillet.

Opiunea Mirror Dac se dorete duplicarea (oglindirea) piesei fa de o anumit fa a acesteia, procedura de lucru este urmtoarea: - Se selecteaz faa fa de care se face oglindirea (fig. 9); - Se selecteaz opiunea Mirror, numele feei selectate anterior apare n cmpul corespunztor din dialogul Mirror Definition; - Se alege OK, piesa este oglindit, operaia efectuat fiind trecut n arborele de comenzi (fig. 11).

Fig. 9. Selectarea feei fa de care se oglindete piesa.

Fig. 10. Definition.

Dialogul

Mirror

Fig. 11. Piesa obinut dup comanda Mirror. Opiunea Pocket Pe suprafaa de sus a piesei modelat anterior se deseneaz schia unui cerc, care apoi este constrns geometric i dimensional (fig. 12).

Fig. 12. Crearea i constrngerea unei schie.

Fig. 13. Dialogul Pocket Definition.

Pentru obinerea unui buzunar: - Se selecteaz cercul anterior schiat; - Se alege opiunea Pocket prin apsarea iconului corespunztor acestei comenzi; - Se definesc limitele Type: Up to last, ceea ce nseamn c buzunarul se va limita la ultima fa ntlnit, adic la faa de la baza piesei (fig. 13); - Se alege OK, rezultnd piesa Fig. 14. Aplicarea opiunii Pocket. din figura 14. Opiunea Shell Aplicarea opiunii Shell presupune parcurgerea urmtoarelor operaii: - Se selecteaz baza piesei (fig.15) i iconul Shell; - Se introduce n cmpul Inside Thickness valoarea de 5 mm (n locul valorii implicite de 1 mm) i se alege OK (fig. 16).

Fig. 15. Selectarea bazei piesei. Fig. 16. Aplicarea opiunii Shell. Opiunea Shaft Prin utilizarea instrumentelor specifice obinerii unei schie se traseaz profilul din figura 17, iar pentru obinerea modelului tridimensional al unui arbore se procedeaz: - Se selecteaz profilul schiei, axa de rotaie i se Fig. 17. Selectarea schiei. alege iconul Shaft; o - n dialogul Shaft Definition (fig.18) se introduc valorile 360 n o cmpul The First Angle, 0 pentru Second Angle; - Se alege OK, ceea ce se obine este arborele din figura 19.

Fig. 18. Dialogul Shaft Definition.

Fig. 19. Modelul 3D al arborelui.

Cele dou limite afiate n figura 19 i anume LIM1 i LIM2 permit modificarea interactiv a valorilor pentru First Angle i Second Angle (fig.20).

Fig. 20. Modificarea limitelor arborelui. Optiunea Groove Comanda necesar crerii unui canal pentru inel elastic este Groove. Se procedeaz astfel: - Se selecteaz iconul corespunztor opiunii; - Se selecteaz schia (profilul i axa trebuie s aparin aceleiai schie); - n fereastra de dialog Groove Definition se introduc parametri dorii (fig.23); - Se aleg limitele canalului: LIM1 i LIM2 (fig. 21), sistemul afieaz canalul care va fi creat (Preview); - Dac utilizatorul este de satisfcut de canalul afiat, confirm operaia alegnd OK; sistemul eliminnd materialul din jurul cilindrului selectat (fig. 22).

Fig. 21. Crearea canalului pentru inel elastic (Preview).

Fig. 22. Aplicarea opiunii Groove. Opiunea Hole

Fig. 23. Dialogul Groove Definition.

Pentru crearea ntr-un solid a unei entiti de tip gaur (opiunea Hole) se procedeaz astfel: - Se alege iconul Hole, se selecteaz muchia circular i faa superioar ca n figura 23. Sistemul CATIA poate acum s defineasc o constrngere de tip distan pentru a poziiona gaura ce va fi creat, concentric cu muchia circular selectat de utilizator (MB3, meniu contextual: Concentricity); - Sistemul CATIA afieaz, fr a crea efectiv, gaura (valori implicite: 10 mm diametru, 10 mm nlime), iar utilizatorul trebuie s introduc valorile dorite n cmpurile corespunztoare din dialogul de creare al gurii (Hole Definition), de exemplu, 24 mm ca valoare a diametrului i 25 mm ca lungime a gurii. n plus, se poate selecta Limit, alegndu-se ntre opiunile Up to plane (gurirea corpului pn la un anumit plan) sau Up to surface (gurire pn la o suprafa plan sau curb); - n cmpul Bottom se opteaz pentru opiunea V-Bottom, o adic se creeaz o gaura nfundat, cu un unghi la vrf de 110 .

Fig. 24. Selectarea entitilor necesare crerii unei guri.

Fig. 25. Crearea de ctre sistem a unei guri cu dimensiunile implicite.

Fig. 26. Crearea efectiva a gurii. Implicit, CATIA V5 creeaz gaura perpendicular pe faa schiei, dar se poate defini i o alt direcie prin anularea opiunii Normal to surface (fig. 26) i indicarea unei muchii sau linii care s fie paralel cu axa gurii.

Fig. 27. Dialogul de alegere a tipului gurii.

Fig. 28. Gaura creat.

- n dialogul Hole Definition se selecteaz opiunea Tab care permite alegerea tipului dorit de gaur (de exemplu, gaura n trepte Counterbored, fig. 27); - Se introduc valori (35 mm ca diametru i 10 mm ca nlime), sistemul afind n Preview forma gurii (fig. 27); - Se alege OK, gaura este creat (fig. 28). Opiunea Stiffener Crearea unei nervuri (element de rigidizare) se face astfel: - Se selecteaz profilul care trebuie extrudat. Acest profil deschis se creeaz ntr-un plan perpendicular pe faa pe care se va gsi elementul de rigidizare (fig. 30). Dac se folosete un profil deschis, utilizatorul trebuie s fie sigur c materialul existent deja poate limita complet extruziunea acestui profil; Fig. 29. Dialogul Stiffener Se apas iconul Definition. corespunztor opiunii Stiffener, ceea ceea ce deschide dialogul Stiffener Definition care ofer o valoare implicit a grosimii (10 mm)elementului de rigidizare (fig. 29). Extrudarea se va face pe trei direcii (indicate prin sgei), dou dintre ele opuse; - Se apas OK, rezultatul fiind prezentat n figura 31.

Fig. 30. Planul n care se creeaz elementul de rigidizare.

Fig.31. Crearea elementului de rigidizare (nervura).

Opiunea Thickness Opiunea prin care se poate modifica grosimea unui corp solid anterior creat n CATIA V5 este Thickness. Etapele care trebuie parcurse n cazul acestei opiuni sunt: - Se apsa iconul Thickness, ceea ce determin afiarea pe ecranul de lucru a dialogului Thickness Definiton (fig. 32); - Se selecteaz feele ce trebuie ngroate (fig. 33); - n cmpul corespunztor se Fig. 32. Dialogul Thickness introduce valoarea dorit (pozitiv), Definition. de exemplu 15 mm; - Se apas OK, rezultatul fiind prezentat n figura 34.

Fig. 33. Selectarea feelor. Opiunea Draft from Reflect Lines

Fig. 34. Corpul obinut.

Procedura de lucru a opiunii Draft from Reflect Lines este urmatoarea: - Se activeaz comanda i este afiat caseta de dialog, pe ecran aprnd i o sgeata care indic direcia implicit de tragere - Se selecteaz cilindrul (fig. 35), CATIA V5 detecteaz dou linii de oglindire (afiate cu roz), acestea fiind folosite pentru a susine feele nclinate. o - Se introduce o valoare (de exemplu 15 ) n cmpul corespunztor unghiului; - Se apas butonul More pentru a extinde dialogul afiat anterior (fig. 36);

Fig. 35. Selectarea liniilor de oglindire. - Se selecteaz opiunea Draft with parting element i se selecteaz ca element de separare faa dreptunghiular amplasat dedesubtul cilindrului; - Se alege OK, feele adiacente feei selectate sunt tiate de elementul de separare, dar ele nu sunt nclinate, doar faa selectat este nclinat (fig. 37). Opiunea Split

Fig. 36. Dialogul extins Draft Reflect Line Definition.

Fig. 37. Aplicarea opiunii Draft from Reflect Lines.

Opiunea Split este folosit pentru a mpari corpul solid n dou sau mai multe pri. Procedura de lucru presupune parcurgerea etapelor de mai jos: - Se selecteaz corpul ce se dorete mprit (fig. 39);

Fig. 38. Dialogul Split Definition.

Fig. 39. Selectarea corpului.

Fig. 40. Rezultatul opiunii Split

- Se selecteaz iconul i suprafaa dup care se dorete mprit corpul, pe ecran fiind afiat dialogul Split Definition (fig. 38) i o sgeat care indic poriunea din corp care va fi pstrat; - Se accept direcia de divizare implicit sau se selecteaz direcia opus; - Se alege OK, operaia efectuat este trecut n arborele de comenzi (fig. 40). Opiunea Sew Surface Aceast opiune este utilizat pentru a ataa ("coase") o anumit suprafa la un corp. Se procedeaz n felul urmtor: - Se selecteaz suprafaa (indicat prin sgeat) care se dorete ataat (fig. 41); - Se selecteaz opiunea ceea ce are ca efect afiarea dialogului Sew Surface Definition (fig. 42) indicnd obiectul ce va fi "cusut"; o sgeat indic partea din material care va fi pstrat (fig. 43).

Fig. 41. Selectarea suprafeei.

Fig. 42. Dialogul Sew Surface Definition.

Fig. 43. Partea din material ce va fi pstrat. Opiunea User Pattern

Fig. 44. Corpul rezultat.

n CATIA V5 crearea unei matrice de obiecte se face selectnd iconul User Pattern; - Se selecteaz entitatea de duplicat (de exemplu, o gaur, fig. 45), pe ecran fiind afiat dialogul User Pattern (fig. 46) n care gaura selectat este trecut automat n cmpul Object.

Obiectele sunt create cu limitele Up to Next (Up to Last, Up to Plane sau Up to Surface) definite pentru entitatea Fig. 45. Entitatea Fig. 46. Dialogul originar. selectat. User Pattern. Se indic, n cmpul Number, numrul de entiti, identice cu cea selectat, care se doresc construite, sistemul afieaz 10, dintre acestea se elimin cele nedorite (fig. 47) Fig. 47 . Multiplicarea entitilor. i se alege OK. Opiunea Adding Bodies Se consider urmtorul exemplu: o pies (fig. 48) este alctuit din trei corpuri independente. Pentru a aduga corpul 1 (Body.1) la corpul de baz: - Se selecteaz corpul 1 (Body.1); - Se selecteaz opiunea Add sau Edit>Body.1.object>Add, pe ecran apare fereastra de dialog Part Body (fig. 49) i se alege OK.

Fig. 48. Selectarea corpurilor de unit.

Fig. 49. Dialogul Add.

Dup executarea operaiei Add ntre Body1 i PartBody materialul comun acestora a fost eliminat (fig. 50), iar operaia executat este trecut n arborele de comenzi.

Fig. 50. Aplicarea operaiei Add.

Opiunea Removing Bodies Operaia invers celei prezentate anterior este Removing Bodies, ceea ce nseamn eliminarea corpului 1 din corpul de baz. - Se selecteaz Edit>Body.1.object>Remove. n cazul n care corpul de baz este alctuit din mai mult de dou corpuri, sistemul solicit selectarea explicit a celui care trebuie eliminat (de exemplu, extragerea cilindrului din figura 51 din corpul de baz).

Fig. 51. Selectarea corpului de extras.

Fig. 52. Rezultatul opiunii Remove Bodies.