Sunteți pe pagina 1din 43

INIŢIERE ÎN GEOMEDIA

1
Geomedia - Generalităţi
GEOMEDIA este o platformă GIS (Geographical Informational System sau Sistem
Informaţional Geografic) realizată de firma INTERGRAPH (care este al doilea
producător din lume, ca mărime, după firma ESRI).
Produsele GeoMedia Professional sunt folosite de către cei mai mulţi utilizatori în
faza de producţie şi exploatare primară de date spaţiale, deoarece este mai uşor de folosit
(comparativ cu produsele din platforma ESRI anume ArcInfo, ArcView şi ArcGIS) şi
conţine un număr impresionant de instrumente specifice GIS.
În acest capitol se vor prezenta meniurile principale ale acestui software,
enumerându-se cele mai importante comenzi care vor fi explicitate mai pe larg în
capitolele următoare.

1. Utilizarea unui GeoWorkspace


GeoWorkspace-urile sunt fişierele specifice platformei GeoMedia, în acestea se
stochează setările spaţiului de lucru şi alte elemente caracteristice acestuia, având extensia
“.gws”.
NOTĂ: Informaţiile referitoare la datele grafice şi/sau textuale ale spaţiului de lucru sunt
stocate în baze de date (de tip Acces, SQL Server etc), nu în fişierul de tip .gws, acestea
putând fi accesate simultan de către mai mulţi operatori.

1.1. Deschiderea unui GeoWorkspace existent


Deschiderea unui GeoWorkspace existent se poate face astfel:
a) prin dublu click pe fişier, localizat prin intermediul unui program de gestionare a
fişierelor (Windows Explorer, Total Commander etc.)
b) porniţi programul GeoMedia. După pornirea programului va apare fereastra de dialog
Welcome to GeoMedia Professional, selectaţi butonul Open existing GeoWorkspace.
Apoi, selectaţi More Files din listă şi căutaţi GeoWorkspace-ul dorit, de exemplu P:\099-
test\Vector\GWS\test.gws .

2
NOTĂ: Prin deschiderea unui GeoWorkspace existent setările spaţiului de lucru şi
diverse elemente caracteristice GeoMedia (interogări, intersecţii spaţiale etc.) sunt deja
realizate.

1.2. Crearea unui GeoWorkspace


Pentru a crea un GeoWorkspace nou se deschide Geomedia, în fereastra de dialog
se bifează Blank GeoWorkspace.

În cazul în care fereastra de dialog este ca în figura de mai jos

se bifează opţiunea Document şi se validează cu New.

NOTĂ: La deschiderea unui GeoWorkspace nou este foarte important ca sistemul de


coordonate cu care se va lucra să fie cel corect. În acest scop se verifică setările din
meniul Tools > Options.

3
Pentru a se putea stabili un singur sistem de coordonate pentru bazele de date ce
vor fi create este necesar a se verifica dacă se păstrează setările din figura de mai jos.

2. Prezentarea GeoWorkspace -ului


Un GeoWorkspace este caracterizat de:
a) bara de meniuri – care conţine meniurile necesare exploatării planului digital;
b) iconuri de lansare a comenzilor – permite lansarea rapidă a comenzilor necesare
prelucrării planului digital;
c) fereastra de lucru – fereastra în care sunt vizualizate datele grafice sau textuale din
planul digital;

4
d) fereastra de dialog – fereastra în care GeoMedia afişează caracteristici de stare
(comenzi lansate în execuţie, scara la care se află planul digital etc.).

2.1. Meniul File


Meniul File conţine instrucţiuni pentru operarea cu fişierele de tip GeoWorkspace
şi instrucţiuni pentru printare.
Se regăsesc funcţiile specifice pentru deschiderea, crearea unui GeoWorkspace
nou, salvare, setarea paginii, printare etc.
O parte din aceste comenzi le găsiţi şi în toolbar-ul Standard

5
2.2. Meniul Edit
Meniul Edit conţine comenzi de anulare a operaţiunilor executate recent (Undo,
Redo), comenzi de selecţie funcţie de conţinutul legendei, comenzi de editare a
geometriilor (crearea sau ştergerea de geometrii, editarea geometriilor existente, editarea
atributelor geometriilor, etc.)

2.3. Meniul View


Meniul View conţine instrumente necesare vizualizării datelor grafice (comenzile
de Zoom, Fit All, etc.), a setărilor spaţiului de lucru (GeoWorkspace Coordinate
System), a diferitelor facilităţi în utilizarea spaţiului de lucru (Legend, North Arrow,
Scale Bar), comenzi de modificare a parametrilor de vizualizare (Display Properties) şi
comenzi de afişare a iconurilor de lansare a comenzilor.

2.4. Meniul Insert


Meniul insert permite:
- adăugarea de geometrii noi (Feature);

6
- adăugarea de cercuri (prin specificarea centrului şi a razei, a două puncte diametral
opuse sau a trei puncte), numai pe Feature class de tip suprafaţă (Circle);
- inserarea imaginilor georeferenţiate (imagini care sunt aşezate pe coordonate –
Georeferenced Images);
- inserarea interactivă a imaginilor (Interactive Image);
- inserarea geometriilor de tip text (Text);
- inserarea etichetelor (Label, Interactive Label, Leader Line);
- inserarea suprafeţelor (Area By Face, Interactive Area By Face);
- inserarea punctelor la intersectia a doua cercuri (Point by Radii).

2.5. Meniul Tools


Meniul Tools conţine instrumente pentru: validarea geometriilor, georeferenţierea
imaginilor şi a elementelor grafice, vizualizarea fişierelor de tip MicroStation (.dgn),
măsurarea distanţelor între două puncte şi pentru personalizarea setărilor necesare lucrului
cu GeoMedia (Customize şi Options)

7
2.6. Meniul Analysis
Meniul Analysis permite:
- efectuarea unor interogări asupra claselor de elemente (feature class-urilor);
- geocodare coordonate (citirea coordonatelor din fişiere de tip Excel, dBASE,
Paradox, Text);

2.7. Meniul Warehouse


Meniul Warehouse conţine instrumente ce permit gestionarea conexiunilor la
bazele de date cu care se lucrează, a feature class-urilor create în aceste baze de date,
exportul datelor în diferite programe similare.
Warehouse > New Warehouse crează o nouă bază de date.
Warehouse > New Conection face o conexiune la o bază de date.
Warehouse > Edit Conection vizualizează conexiunile existente, permiţând
editarea acestora.
Warehouse > Spatial Filters vizualizează doar geometriile care sunt cuprinse în
interiorul ariei definite prin: by View, by Fence, by Area (Spatial Filters – gestionează
filtrele create în Workspace).
Warehouse > Output to Feature Classes exportă geometriile conţinute de un
feature class dintr-o conexiune sau o interogare, într-un alt feature class (existent sau nou)
în aceeaşi sau în altă conexiune.
Warehouse > Export to exportă feature class-uri în format CAD sau GIS.
Warehouse > Feature Class Definition gestionează feature class-urile (adaugă,
şterge, modifică etc.) şi atributele acestora.

8
2.8. Meniul Legend
Meniul Legend conţine instrumente pentru afişarea datelor în legendă Properties,
adăugarea în legendă a unui feature class, query sau thematic, gestionarea legendelor
predefinite (Name Legend, Legends).

2.9. Meniul Window


Meniul Window conţine comenzi legate de operarea cu ferestrele de tip hartă (date
grafice), date (date textuale) sau layout (hărţi pentru plotare): crearea unei ferestre noi,
aranjarea lor pe ecranul de lucru etc..

9
Pentru inserarea unei ferestre noi de tip hartă (Map Window) selectaţi New Map
Window.
Pentru inserarea unei ferestre noi de tip date (Data Window) selectaţi New Data
Window.
Pentru inserarea unei ferestre pentru plotare selectaţi Layout Window. Comenzile
Tile Horizontally , Tile Vertically şi Cascade vă permit afişarea tuturor ferestrelor în
diferite moduri.

2.10. Meniul Help


Meniul Help conţine un manual de bază cu mai multe capitole Geomedia
Professional Help Topics, un manual pentru dezvoltatori Programming Utilities şi un
tutorial Learning Geomedia Professional. Toate aceste documente sunt scrise în limba
engleză.

3. Crearea conexiunilor la bazele de date


Conexiunile se pot realiza fie la baze de date nou create, fie la cele existente.
Bazele de date pot fi grafice şi/sau textuale.

3.1. Crearea conexiunilor la baze de date nou create


Crearea bazelor de date se face din geomedia urmărind paşii:
- Warehouse > New Warehouse

10
- se selectează tipul de bază de date (de obicei Access template), se verifică tipul de fişier
(Open as Document)

- se indică locul în care se va salva baza de date şi denumirea acesteia

Geomedia va genera, pentru baza de date nou creată, o conexiune care va avea
aceeaşi denumire cu cea atribuită fişierului (în acest caz “test.mdb”).

11
3.2. Crearea conexiunilor la baze de date existente
Conexiunile la baze de date existente se va face astfel:
- Warehouse > New Connection

- se selectează tipul de bază de date la care se va face conexiunea (de obicei Acces), click
“Next”

- se atribuie un nume conexiunii (ex. Connection name > Vector) şi se arată calea către
baza de date „Browse” (ex. Access Database file > \\Localserver\Projects\099-
test\Vector\GM\Existenta.mdb), click “Next”

12
- click „Next”

- se selectează tipul de conexiune, prin care se definesc drepturile asupra bazei de date
(doar citire – read-only, citire şi scriere – read/write, închisă – closed)

4. Crearea claselor de elemente (Feature class-urilor)


Clasele de elemente se pot crea numai pe baze de date a căror tip de conexiune este
read/write, prin apelarea meniului Warehouse > Feature Class Definition. Această
comandă se utilizează şi în cazul editării sau ştergerii feature class-urilor existente.

13
Dacă există mai multe conexiuni create pe Workspace, se selectează conexiunea
(implicit baza de date) pe care se doreşte crearea feature class-ului, în acest moment fiind
active două iconuri:
- New – crează un feature class nou;
- Attach – se poate ataşa un fişier de tip Excel, dBASE, Paradox sau Text.

4.1. Crearea feature class-urilor noi


Trebuie precizat faptul că o bază de date nouă nu are atribuit un sistem de
coordonate (dacă au fost respectate indicaţiile de la punctul 5.1.2.), aceasta efectuându-se
la crearea primului feature class.

Exemplu
Se fac măsurători ale unui corp de proprietate, situat în judeţul Dâmboviţa, urmând
ca acestuia să i se execute planul de amplasament, necesar documentaţiei de întabulare
(înscriere la cartea funciară).
Aceasta fiind tema, se analizează datele de intrare (datele care sosesc de la
operatorii din teren, prelucrate iniţial pentru obţinerea coordonatelor fiecărui punct radiat)
şi cerinţele proiectului (realizarea planului de amplasament).
Cunoscând faptul că pentru realizarea planului de amplasament avem nevoie de:

14
- punctele măsurate din teren, aşezate pe coordonate (în sistemul de coordonate
corespunzător);
- linii cu ajutorul cărora să unim punctele radiate, în vederea închiderii suprafeţelor;
- suprafeţe care definesc corpurile de proprietate;
- suprafeţe care definesc parcelele corpurilor de proprietate;
- suprafeţe care definesc construcţiile aferente corpului de proprietate etc.
Din cele enumerate mai sus se poate spune că sunt necesare cel puţin 5 feature
class-uri:
- Radiate (de tip punct care trebuie să conţină ca atribute: x y z coordonatele
puntului; Nr_Pct numărul punctului; Cod atribut care indică materializarea în
teren a punctului măsurat; Job indică persoana care a efectuat măsurătorile
respective);
- Limite (de tip linie cu atribut Cod, pentru precizarea tipului de limită);
- CProp (de tip suprafaţa, în care se pot crea atribute care să conţină următoarele
informaţii: nume şi prenume proprietari; adrese proprietari; adresă corp proprietate;
informaţii referitoare la actul de proprietate, etc);
- Parcele (de tip suprafaţa, în care se pot crea atribute referitoare la categoria de
folosinţă, destinaţia parcelei etc.);
- Const (de tip suprafaţa, în care se pot crea atribute referitoare la numărul
construcţiei în corpul de proprietate, denumirea şi destinaţia acesteia, alte
observaţii etc.).

Lansarea comenzii Warehouse > Feature Class Definition conduce la afişarea


ferestrei Feature Class Definition (figura de mai sus, fereastra din stânga sus). Pentru
crearea unui feature class pe conexiunea test, click pe iconul New.
În fereastra care apare (fereastra din dreapta sus) se definesc:
a) în tabul General:
- Name > Radiate (numele feature class-ului creat);
- Geometry type > Point (tipul de geometrie atribuit feature class-ului). Trebuiesc
precizate tipurile de geometrie cu care geomedia lucrează: Point (puncte); Line
(linie); Area (Arie); Compound (compus, acesta putând conţine atât geometrii de
tip punct, linie cât şi suprafaţă); Image (raster – imagini scanate); Text (text) şi
None (feature class-uri fără geometrie – conţin date textuale).

- Coordinate system > în cazul în care feature class-ul creat este primul pe baza de
date, în căsuţă nu va fi atribuit un sistem de coordonate. Atribuirea unui sistem de

15
coordonate se va face prin click pe iconul New, comandă ce va conduce la apariţia
ferestrei din stânga jos, fereastră în care se definesc parametrii sistemului de
coordonate. Aceşti parametrii se pot defini prin parcurgerea taburilor (General;
Storage Space; Projection Space etc.) sau se regăsesc în fişiere cu extensia “.csf”.
În cazul proiectelor naţionale (care se desfăşoară pe teritoriul României) sistemul
de coordonate utilizat este “Romania.csf”, fişier care trebuie să se regăsească în
directorul “C:\Romania_mm.csf”. De asemenea se verifică şi existenţa fişierelor:
“C:\Romania.csf”; „C:\ROM_COOR.dgn” şi “C:\font.rsc”, fişiere utile
lucrului cu Geomedia. Atribuirea sistemului de coordonate “Romania.csf” se va
efectua prin click pe iconul “Load” şi selectarea (în fereastra “Load Coordinate
System From File” – fereastra din dreapta jos - a fişierului situat pe calea indicată
“C:\Romania_mm.csf”).
b) în tabul Attributes se definesc atributele necesare definirii complete a feature class-
ului.

Trebuie precizat faptul că fiecare feature class trebuie să conţină o cheie de


identificare (linia marcată din figura de mai sus), pentru care se vor face, în mod obişnuit,
setările din figură.
Fiecare atribut creat va primi un nume “Name” şi tipul datelor înregistrate “Type”
(în funcţie de caracteristicile datelor pe care trebuie să le conţină: text, byte, numere
întregi, numere zecimale, etc.).

NOTĂ: În mod asemănător se va proceda şi pentru crearea feature class-urilor următoare.


Sistemul de coordonate nu va mai fi atribuit celorlalte feature class-uri prin click pe
iconul New şi va fi atribuit prin selectarea din listă a sistemul de coordonate încărcat (în
mod normal acesta se va selecta singur).
16
4.2. Crearea feature class-urilor de tip “Attach”
În exemplul dat este necesar a se face un ataşament al fişierului în care sunt stocate
informaţiile referitoare la punctele radiate măsurate în teren, cu prelucrările ulterioare
astfel încât coordonatele punctelor să fie calculate, în vederea generării automate a
punctelor în baza de date aferentă. Acest fişier se regăseşte pe calea P:\099-
test\Job\teleasa.xls.

NOTA: Înaintea efectuării ataşamentului se verifică existenţa compatibilităţii între tipul


datelor existente în fişierul mai sus menţionat şi tipul de date atribuit câmpurilor create în
feature class-ul Radiate (Nr_Pct, x, y, z, Cod, Job)
Pentru ataşarea fişierului se va executa următoarea succesiune de comenzi:
- Warehouse > Feature Class Definition

- click pe iconul Attach

Se vor indica:
- Data source information – tipul de fişier ataşat (în acest caz Excel);
- Source – se indică structura de directoare către fişierul ataşat;
- Tables to attach – se precizează numele Worksheet-ului din care se vor citi datele
(Source table) şi numele atribuit ataşamentului în baza de date.

17
5. Vizualizarea datelor
Datele pe care le putem vizualiza cu Geomedia pot fi date textuale şi grafice.

5.1. Vizualizarea datelor textuale


Vizualizarea datelor textuale se face într-o fereastră de tip Data Window, care se
accesează:
- din meniul Window > New Data Window (în cazul în care se crează o fereastră nouă)

- din meniul Window > Data Window1 (în cazul în care aceasta există şi conţine datele
care ne interesează)

5.2. Vizualizarea datelor grafice


Datele grafice care pot fi vizualizate de Geomedia sunt:
- date grafice de tip vector (feature class-uri, interogări pe attribute şi interogări
spaţiale);
- date grafice de tip raster (imagini scanate).
Modul în care sunt vizualizate şi pot fi accesate datele grafice sunt gestionate într-o
fereastră de tip Map Window, prin intermediul legendei.

18
Legenda dispune de o serie de opţiuni de vizualizare sau accesare a datelor grafice:

- Display On – permite vizualizarea datelor grafice în fereastra de lucru;


- Display Off – nu permite vizualizarea datelor grafice în fereastra de lucru;
- Display by Scale – permite vizualizarea datelor grafice în fereastra de lucru numai
într-un interval de scară indicat;
- Locatable – opţiune care permite sau nu accesarea (selectarea) datelor grafice
(lucru indicat de prezenţa săgeţii în dreptul feature class-urilor – pentru exemplul
din figura de mai jos pentru toate feature class-urile, cu excepţia feature class-ului
Limite, este permisă accesarea datelor). NOTĂ: Această opţiune nu are nici o
legătură cu opţiunile de vizualizare Display On, Off sau by Scale.
- Load Data – permite încărcarea datelor care, din diverse motive, nu sunt
vizualizate (dacă această opţiune nu rezolvă problema se vor căuta alte posibilităţi
de rezolvare);
- Hide Legend Entry – ascunde feature class-ul în legendă, însă vizualizarea şi
accesarea datelor grafice este permisă conform opţiunilor corespunzătoare validate;
- Collapse Legend Entry – opţiune care este activă numai în cazul tematicilor din
legendă (interogări efectuate pe atributele feature class-urilor);
- Fit Legend – permite vizualizarea tuturor intrărilor în legendă;
- Legend – permite închiderea legendei, astfel încât să obţinem o fereastră de lucru
mai mare;
- Properties – opţiune care permite setarea tuturor proprietăţile de afişare ale
elementelor conţinute în legendă.
De exemplu pe tabul Entries găsiţi toate elementele din legendă cu starea
proprietăţilor lor:
- Style indică tipul de feature class;
- Title afişează denumirea feature class-ului;
- Subtitle afişează o denumire ajutătoare (subtitlu), dacă este cazul;
- Display arată starea de afişare a feature class-ului (ON sau OFF);
- Locatable arată dacă feature class-ul este sau nu selectabil;
- Entry permite scoaterea feature class-ului din legendă, geometriile rămân însă
active în fereastra de lucru.
De asemenea este indicată sursa feature class-ului (conexiunea din care este adus)
Source, stilul de vizualizare (tiupul de linie, grosimea etc.) Style, adăugarea sau ştergerea

19
din legendă a feature class-urilor Add şi Delete, intervalul de scară la care să fie
vizualizat feature class-ul Scale.

Pe tabul General sunt opţiuni care ţin de modul de afişare a tuturor elementelor
din legendă. De exemplu dacă se bifează opţiunea Show Statistics, în legendă apare
numărul de elemente conţinut de fiecare feature class.

NOTĂ:
Este foarte important să cunoaştem modul în care Geomedia utilizează opţiunile
din legendă.
Aşezarea feature class-urilor în legendă este o condiţie a utilizării eficiente.
Trebuie cunoscut faptul că în Geomedia planul digital este vizualizat ca o multitudine de
straturi aşezate unul peste altul, în ordinea aşezarii feature class-urilor în legendă.
Pentru exemplul prezentat, la aşezarea feature class-urilor în legendă, în scopul
realizării planului digital (vectorizării), se au în vedere următoarele:
- feature class-ul Radiate (de tip punct) este aşezat primul în legendă;
- urmează feature class-ul Limite (de tip linie);
- la aşezarea feature class-urilor de tip suprafaţă se ţine seama de faptul că feature
class-ul CProp este cuprinzător feature class-ului Parcele, care este cuprinzător
feature class-ului Const, deci aşezarea în legendă va fi în ordinea: Const, Parcele,
CProp.

20
Vizualizarea datele în fereastra de lucru se poate face utilizând funcţiile aflate pe
toolbar-ul Standard.
Pentru afişarea acesteia selectaţi toolbar-ul Standard din meniul Tools >
Customize > Toolbars.

Puteţi mări sau micşora zona de interes selectând Zoom in sau Zoom out
vă puteţi deplasa selectând Pan , selectând Fit Select Set aveţi o imagine a zonei
corespunzătoare elementelor selectate (condiţia ca acest icon să fie active este existenţa
cel puţin a unei geometrii selectate), iar selectând Fit All aveţi o imagine de
ansamblu.

5.2.1. Vizualizarea datelor grafice de tip vector


a) Vizualizarea feature class-urilor
Aducerea unui feature class în legendă se poate face:
a.1) din meniul Legend > Add Feature Class

selectarea conexiunii (ex. Connection > test) şi a feature class-urilor din conexiunea
respectivă (ex. Cprop, Parcele), care se doresc aduse în legendă.

21
a.2) cu ajutorul iconului corespunzător Add Feature Class Legend Entry

b) Vizualizarea query-urilor (interogărilor)


Query-urile sunt instrumente specifice GIS care permit vizualizarea datelor grafice
sau textuale funcţie de atributele feature class-urilor (attribute query) sau funcţie de
poziţia reciprocă a datelor grafice (spatial query, spatial intersection, spatial difference
etc.).
b.1) Interogările pe atribute (attribute query) permit căutarea înregistrărilor din baza de
date, pentru o valoare specificată sau o serie de valori, ale unui atribut sau o combinaţie
de atribute, aplicate asupra unui feature class.
Acestea sunt create din meniul Analysis > Attribute Query.

Se specifică conexiunea şi feature class-ul pe care se face interogarea (ex. Limite).

22
Prin iconul Filter se activează fereastra în care se construieşte interogarea.
De exemplu, se doreşte vizualizarea înregistrărilor din feature class-ul Limite al
cărui atribut Cod să conţină combinaţia de litere “CO”, astfel încât să putem localiza
construcţiile.
În acest caz se selectează în fereastra Attributes câmpul pe care se aplică
interogarea (Cod), se identifică operatorul corespunzător selecţiei dorite (pentru cazul
prezentat, unde interesează selectarea înregistrărilor care conţin codul CO, nu a celor
strict egale cu CO, se va selecta operatorul LIKE) şi se indică valoarea (Values)
atributului ce se doreşte vizualizat (CO). Click OK.

Se defineşte numele query_ului (Ex. Query name Limite_CO), se selectează


metoda de vizualizare (Display query in map window, Display query in data window
sau ambele opţiuni) şi stilul (Style).

b.2) Interogările spaţiale (Spatial query, Spatial Intersection, Spatial Difference etc.)
extrag informaţii din bazele de date, despre două feature class-uri sau query-uri care se
află într-o relaţie spaţială unul referitor la celălalt.

5.2.2. Vizualizarea datelor grafice de tip raster


Datele grafice de tip raster pot fi:
- imagini cărora le este atribuit un sistem de coordonate (imagini georeferenţiate), care se
regăsesc în directorul “Raster\Arhiva” din cadrul proiectului sau pe serverul
RasterServer (de ex. ortofotogramele);
23
- imagini negeoreferenţiate care se regăsesc în directorul “Raster\Scan” din cadrul
proiectului.
Pentru inserarea imaginilor georeferenţiate se va proceda astfel:
a) din meniul Insert > Georeferenced Images

b) În caseta corespunzătoare Georeference mode se alege din listă modul de


georeferenţiere al imaginii respective (recomandări: pentru imagini cu extensia .tif >
Intergraph header matrix, pentru cele cu extensia .sid > World file);
c) În caseta Coordinate system file se specifică sistemul de coordonate corespunzător
(pentru recomandările de mai sus: Romania_mm.csf - în cazul fişierelor .tif;
Romania.csf – în cazul fişierelor .sid);
d) În caseta Folder se indică directorul în care se găsesc imaginile ce se vor încărca în
geomedia;
e) Opţional în caseta Extensions se poate indica tipul de fişier căutat, lista de fişiere fiind
actualizată în concordanţă cu cerinţele (ex. *.tif – va genera lista fişierelor cu extensia .tif)
f) În lista fişierelor disponibile (Available files), se selectează unul sau mai multe fişiere

după care click pe iconul , pentru a plasa imaginile selectate în caseta Selected
files. Pentru selectarea tuturor fişierelor din lista Available files se utilizează iconul

.
g) În caseta corespunzătoare Warehouse se selectează conexiunea (baza de date) pe care
se doreşte stocarea căilor către imagini.
NOTĂ: Pentru a se putea aduce în geomedia imagini georeferenţiate este necesară
existenţă unei conexiuni read/write la o bază de date.
h) În caseta Feature class se selectează feature class-ul în care se doreşte adăugarea
imaginilor sau se scrie numele unui nou feature class.
NOTĂ: La crearea unui nou feature class, numele acestuia trebuie să înceapă cu o literă şi
nu trebuie să conţină caracterele “-“, “\”, “/”, “=”, “(“, “)” etc., în caz contrar iconul OK
nu va fi activ.
i) Opţional Numai în cazul creării unui nou feature class, se poate selecta modul de
vizualizare a imaginii prin verificarea casetei “Add new legend entry for feature class”

24
(la selectarea acestei opţiuni feature class-ul va fi adăugat în legendă, în caz contrar acesta
va fi creat în baza de date dar nu va fi vizualizat în fereastra de lucru).
j) Click pe iconul OK sau Apply.

Modificarea proprietăţilor de vizualizare a imaginii se poate realiza prin dublu


click pe icon-ul rasterului selectat.

În caseta de dialog Image Display, click Set Foreground Color.


În caseta de dialog Color, alegeţi o culoare. Nu utilizaţi aceleaşi culori pe care le-
aţi utilizat pentru celelalte obiecte.
Pentru imaginile alb-negru se poate selecta Transparency.
Apăsaţi butonul OK în caseta de dialog. Culoarea imaginii raster este schimbată

25
6. Editarea datelor
Presupune editarea datelor grafice sau textuale (elemente) fie prin crearea unor noi
elemente, fie modificarea celor existente.

6.1. Crearea de noi elemente


a) Pentru crearea de noi elemente a caror geometrie este de tip punct, linie, suprafata sau
compusa, se poate proceda astfel:
Meniul Insert > Feature sau

icon-ul corespunzător

Se precizează conexiunea şi feature class-ul pe care se va crea elementul nou.

26
Se vectorizează (digitizează) geometria (folosind ca suport fie imaginea, fie
punctele măsurate din teren etc.). Închiderea comenzii se face prin dublu click.
În cazul în care este activat icon-ul Display Properties Dialog For New Features

va fi afişată fereastra de proprietati pentru geometria nou creata, unde se vor putea
completa atributele corespunzătoare.

b) Pentru crearea de noi elemente a caror geometrie este de tip text, se poate proceda
astfel:
b.1) Meniul Insert > Text sau

icon-ul corespunzător

27
Se precizează conexiunea şi feature class-ul pe care se va crea elementul nou.

Se tastează textul dorit şi se amplasează textul în poziţia corespunzătoare.


Ca şi în cazul vectorizării elementelor de tip punct, linie, suparafaţă sau compus, în
cazul în care este activat icon-ul Display Properties Dialog For New Features, va fi
afişată fereastra de proprietati pentru geometria nou creata, unde se vor putea completa
atributele corespunzătoare.

b.2) În cazul în care elementul de tip text trebuie să conţină valoarea corespunzătoare unui
atribut al unui feature class de tip punct, linie, suprafaţa sau compus se va utiliza comanda
din meniul Insert > Interactive Label sau

icon-ul corespunzător

28
Se precizează:
- conexiunea şi feature class-ul de tip punct, linie, suprafaţă sau compus ce conţine
informaţiile ce se doresc copiate în feature class-ul de tip text
- din lista de atribute disponibile se vor selecta atributele ce contin informatiile ce se
vor copia
- conexiunea şi feature class-ul de tip text in care se vor copia informatiile
- se specifică parametrii de simbolizare pentru text nou creat.

Se selectează geometria corespunzătoare feature class-ului de tip punct, linie,


suprafaţă sau compus specificat anterior,

29
După care se specifică poziţia textului creat.

c) Inserarea liniilor de referinţă Leader Lines


Permite afişarea valorilor atributelor unui feature class sau query, prin digitizarea
unor linii de referinţă, în locul în care doreşte operatorul. Pentru ca acest lucru să fie
permis este necesar ca iniţial să fie creat acest feature class de tip leader lines.
Din meniul Insert > Label

Se deschide fereastra de dialog Insert Label.

30
Se vor specifica:
- conexiunea si feature class-ul pentru care se vor vizualiza valorile atributelor;
- atributele vizualizate şi parametrii de amplasare;
- denumirea interogării (query-ului);
- conexiunea şi denumirea feature class-ului corespunzător liniilor de referinţă;
- denumirea MapWindow-ului în care vor fi afişate informaţiile;
- stilul de simbolizare al textului aferent valorilor atributelor selectate pentru vizualizare.
NOTĂ:
a) În cazul în care se doreşte decât afişarea valorilor atributelor, nu şi crearea liniilor de
referinţă, opţiunea Enable leader lines va fi dezactivată;
b) În cazul în care se doreşte crearea unui feature class de tip text cu valorile atributelor
specificate anterior se va activa opţiunea Feature class. În acest caz în fereastra de dialog
vor fi activate căsuţele necesare specificării locului (conexiunii) unde se va crea feature
class-ul şi denumirii feature class-ului de tip text.

6.2. Modificarea elementelor existente


Comenzile de editare a elementelor existente pot fi lansate în execuţie din meniul
Edit. Pentru o mai mare eficienţă se pot utiliza icon-urile corespunzătoare.

Pentru afişarea acestor icon-uri (în cazul în care acestea nu sunt afişate) se
utilizează meniul View > Toolbars, în fereastra de dialog Toolbars activându-se toate
opţiunile.

31
Icon-urile de editarea a elementelor existente sunt:
- Insert Feature - se selectează conexiunea şi feature class-ul (de tip punct,
linie, arie sau compus) care se inserează;
- Insert Text - se selectează conexiunea şi feature class-ul (de tip text) care se
inserează;
- Interactive Label - se selectează conexiunea şi feature class-ul ale cărui
atribute se vor copia şi se specifică feature class-ul de tip text pe care se vor copia
aceste atribute
- Insert Leader Line - pentru ca această comandă să poată fi executată este
necesară existenţa unui feature class de tip Leader Line. Acesta se poate crea din
meniul Insert > Label,

specificându-se conexiunea, feature class-ul şi atributele pentru care se crează


Leader Line-ul, se selectează Enable leader lines şi se specifică conexiunea şi
feature class-ul corespunzătoare liniilor de referinţă (Leader Line).

32
Crearea Leader Line se realizează prin selectarea etichetei (Label) şi activarea
icon-ului .
- Edit Geometry - comandă ce permite editarea vertex-ilor unei geometrii.
Acest icon este activ numai la selectarea unei geometrii.
- Continue Geometry - permite continuarea unei geometrii existente. Acest
icon este activ numai la selectarea unei geometrii.
- Redigitize Geometry - permite modificarea unei geometrii, prin selectarea
zonei care se doreşte modificată şi indicarea traseului corect. Acest icon este activ
numai la selectarea unei geometrii.
- Trim - permite scurtarea unei geometrii, fie interactiv (cu mouse-ul), fie prin
precizarea valorii distanţei cu care se scurtează.
- Trim to intersection - permite scurtarea unei geometrii până la intersecţia
acesteia cu altă geometrie.
- Extend - permite alungirea unei geometrii, fie interactiv (cu mouse-ul), fie
prin precizarea valorii distanţei cu care se scurtează.
- Extend to intersection - permite alungirea unei geometrii până la intersecţia
acesteia cu altă geometrie.
- Insert intersection - inserează vertex pe geometriile care se intersectează.
- Move - permite mutarea geometriilor, precizându-se punctele sursă şi ţintă.
- Spin - permit rotirea unei geometrii de tip punct sau text în raport cu punctul
său de inserţie.
- Rotate - permite rotirea geometriilor în raport cu un punct, specificat cu
mouse-ul.
- Split Feature - realizează împărţirea unui element în alte elemente.

33
- Merge Features - realizează unirea a două sau mai multe elemente selectate,
ale aceluiaşi feature class.
- Copy Feature - permite copierea geometriilor selectate, existente.
- Delete - permite ştergerea geometriilor selectate.

7. Comenzi utile
7.1. Moduri de selecţie a elementelor grafice
Pentru selectarea elementelor grafice se folosesc opţiunile din bara de instrumente
Selection.

34
Pentru afişarea acestor icon-uri (în cazul în care acestea nu sunt afişate) se
utilizează meniul View > Toolbars, în fereastra de dialog Toolbars activându-se
Selection.

Instrumentele de selecţie sunt activate în cazul în care altă comandă nu este activă,

lucru indicat şi de starea iconu-ului Select tool ( - activ şi - inactiv).


Atunci când Select tool este activ, selecţia elementelor grafice se poate realiza
astfel:
- selecţia individuală a elementelor grafice (se realizează prin selectarea individuală,
cu mous-ul, a fiecărui element grafic – pentru selecţie multiplă se va ţine tasta Ctrl
apăsată până la selectarea tuturor entităţilor);
- selecţia tuturor elementelor grafice cuprinse în interiorul unei limite, Inside fence.
Se realizează prin definirea unei limite care să cuprindă elementele selectate în
interiorul acesteia. Limita de selecţie va fi reprezentată de o suprafaţă
dreptunghiulară în cazul în care este activată opţiunea Deault Selection, sau de o
suprafaţă de tip poligon în cazul în care este activată opţiunea Polygonal
Selection.
- selecţia tuturor elementelor grafice cuprinse în interiroul unei limite, sau cel puţin
atinse de aceasta, Overlap Fence. Se realizează în mod asemănător cu selecţia
Inside Fence.
NOTĂ:
a) La realizarea selecţiei se vor avea în vedere şi proprietăţile intrărilor în legendă
(Display On; Display Off; Locatable On; Locatable Off etc.);
b) Cele trei moduri de selecţie pot fi combinate, cu condiţia utilizării tastei Ctrl;
c) Dacă într-un set de elemente selectate se doreşte deselectarea unui element se va ţine
tasta Ctrl apăsată şi se va da click pe elementul ce se doreşte deselectat.

35
7.2. Utilizarea opţiunilor SmartSnap

Bara de instrumente SmartSnap conţine icon-uri care permit cu uşurinţă activarea


sau dezactivarea opţiunilor de snap atât pentru raster cât şi pentru vector. Pentru ca aceste
opţiuni să fie accesate trebuie ca fereastra de lucru să fie de tip MapWindow.

- Intersection snap (vector) – snap intersecţie elemente grafice

- End point snap (vector) – snap capăt de element grafic

- Vertex snap (vector) – snap nod (vertex) element grafic

- On element snap (vector) – snap pe element grafic

- Origin snap (vector) – snap punct origine element grafic (pentru elemente grafice
de tip punct sau text)
- Midpoint Snap (vector) – snap pe mijloc segment element grafic

- Intersection snap (raster) – snap intersecţie pentru rastere (imagini)

- End of line snap (raster) – snap capăt de linie raster

- Corner snap (raster) – snap colţ raster


- Open symbol snap (raster) – snap simbol gol la interior raster

- Closed symbol snap (raster) – snap simbol plin raster

- Center snap (raster) – snap centru raster

7.3. Utilizarea opţiunilor de editare “Options”

Această bară de instrumente permite controlul asupra modului de editare.

a) Maintain Coincidence

- cu această opţiune activată se permite editarea elementelor geometrice astfel


încât să existe coincidenţă între nodurile (vertex) elementelor grafice. Un vertex este
coincident cu alt vertex dacă au aceleaşi coordonate. Când este activată, această opţiune
crează, şterge sau mută un vertex pentru toate elementele geometrice care sunt selectabile

36
(Locatable On) şi vizibile (Display On) atunci când se execută o acţiune asupra unui
element grafic care implică opţiuni de snap pe elementele grafice de coincidenţă.

b) Break Linear Features

- opţiune care permite spargerea unui element grafic (care are geometrie de tip
linie) în două segmente, în punctul de snap generat la editarea altor elemente grafice.

c) Display Properties Dialog for new features

- permite deschiderea automată a ferestrei de dialog Properties, pentru


completarea atributelor corespunzătoare, atunci când se crează un nou element grafic
(obţinut prin comenzi de editare).

d) Use Existing Geometry when digitizing

- permite folosirea geometriilor existente atunci când se editează una nouă,


această opţiune fiind utilă atunci când două geometrii au acelaşi contur pe toată lungimea
lor sau doar parţial. Geometria nou creată va copia toate nodurile (vertex) geometriei
existente, pe porţiunea pe care acestea sunt identice.

8. Plotarea planurilor
Paşii care trebuiesc urmăriţi la realizarea planurilor şi printarea acestora sunt:
- stabilirea formatului hârtiei pe care se va realiza printarea;
- crearea planului, prin aşezarea elementelor componente ale planului

8.1. Stabilirea formatului hârtiei pe care se va realiza printarea

Pentru printarea planurilor se utilizează fereastra de printare Layout Window,


fereastră ce se deschide din meniul Window > Show Layout Window, în cazul în care
nu se regăseşte în lista ferestrelor disponibile în GeoWorkspace.

37
În funcţie de datele care se cunosc se stabileşte formatul de hârtie pe care se va
realiza plotarea, ţinându-se cont de următoarele:
- formatul de hârtie maxim disponibil, în funcţie de imprimanta disponibila pe care
se doreşte realizată imprimarea;
- scara la care se doreşte realizarea planului;
- dimensiunile zonei printate (conţinutul planului).
Formatul hârtiei de plotare se stabileşte din meniul File > Page Setup.

Se specifică:
- denumirea curentă a planului;
- se selectează din lista de formate standard formatul corespunzător planului, stabilit
anterior (în cazul în care este necesar un format standard);
- în cazul în care formatul hârtiei nu este un format standard se va selecta Custom în
caseta corespunzătoare Size, caz în care casetele Width, Height şi Units se vor
activa, permiţând operatorului specificarea valorilor şi a unităţii de mărime.
- orientarea hârtiei (portrait sau landscape)

38
8.2. Crearea planului

Pentru crearea planului de printare se au în vedere următoarele elemente conţinute


de acesta:
- cel puţin o zonă cu informaţii grafice;
- titlul planului;
- scara de printare;
- legenda;
- orientarea planului faţă de nord.

a) Pentru aducerea informaţiilor grafice în fereastra de printare, din meniul Insert > Map.

În fereastra de dialog Insert Map se vor specifica:


- denumirea MapWindow pe baza caruia se realizează planul;
- metoda de aducere a informaţiilor grafice;
- scara de plotare;
- modul de legătură cu MapWindow.

În funcţie de metoda de aducere a informaţiilor grafice din MapWindow se pot


distinge:

39
- MapWindow, caz în care zona de printare este definită de dimensiunile fereastrei
grafice din care se aduc informaţiile;
- Existing Shape, se utilizează atunci când se doreşte utilizarea unei geometrii de tip
suprafaţă ca fiind limita zonei ce se doreşte printată;
- Rectangle, zona de printare este definită prin trasarea unui dreptunghi în fereastra
grafică;
- Polygon, zona de printare este definită prin digitizarea unui poligon în fereastra
grafică;
- Paper Size, zona de printare se impune a avea anumite dimensiuni pe hârtia de
printare. Pentru aceasta se vor specifica înâlţimea şi lăţimea zonei de printare;
- Spatial Filter, zona de printare este definită de limitele zonei spacificate în
definirea filtrelor spaţiale (utilizate îndeosebi în cazul bazelor de date cu un număr
mare de geometrii, pentru limitarea zonei analizate);
- Geographic Frame, metodă utilizată în cazul în care coordonatele geografice ale
colţului din stânga sus şi ale celui din dreapta jos, care definesc zona de printare,
sunt cunoscute;
- Projected Frame, metodă utilizată în cazul în care coordonatele colţului din
stânga sus şi ale celui din dreapta jos, care definesc zona de printare, sunt
cunoscute. Aceste coordonate sunt specificate în conformitate cu sistemul de
proiecţie al GeoWorkspace-ului.

În funcţie de diferitele metode adoptate, vor fi disponibile diferite câmpuri


suplimentare, pentru specificarea parametrilor ce definesc zona de plotare.

Modul de legătură între zona de printare şi MapWindow poate fi:


- Static – modificările aduse ulterior în MapWindow nu se vor reflecta automat în
layout Window. Fereastra grafică de tip static poate fi schimbată temporar (pentru
actualizare) în fereastră grafică de tip Dynamic.
- Dynamic – orice modificare adusă în MapWindow va fi actualizată automat î
fereastra Layout Window.
b) Titlul planului
Pentru scrierea de texte, şi nu numai, în fereastra layout window se utilizează bara
de instrumente Drawing.
Scrierea textelor trebuie să fie precedată de selectarea parametrilor textului (font,
mărime, culoare font, aliniament etc.).

Deasemenea, se pot crea diferite entităţi grafice (aceste geometrii vor fi memorate
în GeoWorkspace, nu în bazele de date la care Geomedia este conectată).
c) Scara de printare
Specificarea scării de printare pe plan se poate realiza fie prin editarea textului care
indică scara planului, fie prin generarea unui format de scară standardizat (din meniul

40
Insert > Scale Bar – pentru ca această opţiune să fie activă anterior trebuie selectată zona
grafică pentru care se generează scara).

d) Legenda
Pentru crearea legendei se selectează zona grafică pentru care se generează
legendă, după care se lansează comanda din meniul Insert > Legend.

În fereastra de dialog Insert Legend se vor putea efectua toate modificările


necesare pentru ca legenda să fie definită după necesităţile operatorului.

41
În legendă vor fi aduse toate intrările în legendă care au proprietatea Display On,
putându-se efectua operaţii asupra proprietăţilor (modului de simbolizare), redenumirea,
adăugarea sau ştergerea intrărilor în legendă.

e) Orientarea planului faţă de nord


Pentru crearea nordului se selectează zona grafică pentru care se generează
legendă, după care se lansează comanda din meniul Insert > North Arrow.

În fereastra de dialog Insert North Arrow se va putea specifica: tipul de simbol


folosit şi dimensiunea acestuia.

42
CUPRINS

INIŢIERE ÎN GEOMEDIA..............................................................................................................1
Geomedia - Generalităţi................................................................................................................2
1. Utilizarea unui GeoWorkspace ................................................................................................2
1.1. Deschiderea unui GeoWorkspace existent .......................................................................2
1.2. Crearea unui GeoWorkspace.............................................................................................3
2. Prezentarea GeoWorkspace -ului.............................................................................................4
2.1. Meniul File........................................................................................................................5
2.2. Meniul Edit........................................................................................................................6
2.3. Meniul View......................................................................................................................6
2.4. Meniul Insert .....................................................................................................................6
2.5. Meniul Tools .....................................................................................................................7
2.6. Meniul Analysis.................................................................................................................8
2.7. Meniul Warehouse ............................................................................................................8
2.8. Meniul Legend...................................................................................................................9
2.9. Meniul Window ................................................................................................................9
2.10. Meniul Help ..................................................................................................................10
3. Crearea conexiunilor la bazele de date...................................................................................10
3.1. Crearea conexiunilor la baze de date nou create.............................................................10
3.2. Crearea conexiunilor la baze de date existente................................................................12
4. Crearea claselor de elemente (Feature class-urilor)................................................................13
4.1. Crearea feature class-urilor noi........................................................................................14
4.2. Crearea feature class-urilor de tip “Attach”....................................................................17
5. Vizualizarea datelor................................................................................................................18
5.1. Vizualizarea datelor textuale...........................................................................................18
5.2. Vizualizarea datelor grafice.............................................................................................18
5.2.1. Vizualizarea datelor grafice de tip vector.................................................................21
5.2.2. Vizualizarea datelor grafice de tip raster..................................................................23
6. Editarea datelor.......................................................................................................................26
6.1. Crearea de noi elemente..................................................................................................26
6.2. Modificarea elementelor existente...................................................................................31
7. Comenzi utile..........................................................................................................................34
7.1. Moduri de selecţie a elementelor grafice.........................................................................34
7.2. Utilizarea opţiunilor SmartSnap......................................................................................36
7.3. Utilizarea opţiunilor de editare “Options”.......................................................................36
8. Plotarea planurilor..................................................................................................................37
8.1. Stabilirea formatului hârtiei pe care se va realiza printarea............................................37
8.2. Crearea planului...............................................................................................................39

43