Sunteți pe pagina 1din 34

AutoCAD

Curs 1
Introducere n CAD/CAM/CAE. Interfaa AutoCAD. Tehnici
de introducere a comenzilor. Specificarea coordonatelor
i a distanelor. Limitele desenului, snap-ul i caroiajul.
Deschiderea, salvarea i nchiderea desenelor.

aceste note de curs sunt disponibile la


http://belea.ct.upt.ro

Obiective. Ce este CAD?


 Obiectivele cursului
Introducerea conceptelor i procedurilor CAD
Dezvoltarea unor priceperi practice de utilizare a sistemelor CAD
folosind programul AutoCAD 2004
Desene n plan (2d)

 Ce este CAD?
CAD
Computer Aided Design (Proiectare asistat de calculator)
Computer Aided Drafting (Grafic asistat de calculator)

CAD este un instrument electronic care permite realizarea rapid


a unor desene ngrijite i exacte folosind un calculator
Avantaje fa de metoda tradiional (hrtie + creion)
desene ngrijite i precise
modificare uoar
pregtirea uoar a prezentrilor

AVANTAJE. Desene ngrijite i flexibilitatea editrii


 Desene i uniti precise
Pot fi folosite mai multe formate de reprezentare a unitilor:
zecimal, ingineresc, tiinific, etc.
Precizie ridicat
Evitarea unor calcule consumatoare de timp

 Editare flexibil
Posibiliti diversificate de editare:

Deplasarea sau copierea (multiple) a elementelor


Mrirea sau micorarea scrii desenelor
Comasarea unor desene
Ajustarea dimensiunilor desenului
Modificare nlimii i stilului textelor
Modificarea unitilor cotelor, a preciziei i a stilului de cotare

Reutilizarea desenelor existente sau a unor pri ale acestora


Modificrile nu afecteaz aspectul final al desenului

Stocare, acces i partajare comode


 Sistemul de fiiere al calculatorului:
permite crearea unui mediu puternic organizat: mii de fiiere
accesibile prin clickul unui mouse
utilizarea mai eficient a spaiului de lucru
desenele electronice nu se nvechesc i nu se nglbenesc

 Partajarea:
Reelel de calculatoare (i internetul) permit o partajare i
transmitere comod a desenelor
Proiectele mari pot fi mai uor coordonate (schimbul de date ntre
inginer, arhitect, manager, etc.)
Proiectele mari pot fi abordate n echip

Prezentri. Documentarea proiectelor.


 Prezentri atractive
Utilizarea culorilor, a tipurilor de linii, a haurilor, a simbolurilor
speciale i a stilurilor de text creeaz prezentri atractive
Posibilitatea realizrii prezentrilor pe ecrane
Prezentri animate
Reprezentrile spaiale sunt mai uor de neles de un ne-inginer

 Documentarea proiectelor
Pregtirea unor liste de materiale, de costuri, etc.
Uor de modificat
Eficient pentru proiectele mari

CAD/CAM/CAE
 CAD - Computer Aided Design/Drafting
(Proiectare/Grafic Asistat de Calculator)
 CAM - Computer Aided Manufacturing (Fabricare Asistat
de Calculator)
Sisteme CAD-CAM: automatizarea procesului de fabricaie
Datele de la desenele CAD pot fi folosite direct de sistemele
computerizate de fabricaie (eliminarea imprimrii desenelor)
Acuratee i precizie

 CAE - Computer Aided Engineering (Inginerie Asistat de


Calculator): verificarea de rezisten elementelor
structurale
 Proiectare asistat de calculator pentru diverse
discipline: programe specifice care permit calculul rapid
al unor structuri i componente ale acestora

Transferul informaiilor
 Actual: informaia este transferat de a un sistem
(proiectant) la altul (fabricant) folosind informaia
imprimat (desene pe suport de hrtie)
 n viitor: transferul electronic al informaiei

Exemplu: Desen CAD spaial (3D)

Exemplu: Desen CAD spaial (2D)

Exemplu: CAE

AutoCAD




Un program de referin n universul CAD


Folosit pe larg
Cteva site-uri utile:

http://www.cadtutor.net
http://www.autodesk.com (site oficial)
http://www.we-r-here.com/cad/index.htm

Interfaa
AutoCAD
 suprafaa de
desenare (drawing
area)

UCS
selector (pickbox)
colimator
(crosshairs)

bara titlu (title bar)


barele de meniu
barele de unelte
(toolbar)
 linia de comand
 bara de stare
(status bar)




Interfaa AutoCAD
 Suprafaa de desenare: fereastra grafic - aici est ecreat
desenul
icoana UCS: Sistem de coordonate utilizator (User Coordinate
System) - indic direciile pozitive ale axelor X i Y. Sistemul de
coordonate este folosit pentru introducerea coordonatelor.
Pickbox: este folosit pentru selectarea obiectelor
Crosshairs: indic poziia cursorului

 Bara de titlu (title bar): afieaz numele programului i


numele fiierului curent
 Bara de meniu (menu bars): este folosit pentru
introducerea comenzilor. Majoritatea comenzilor pot fi
introduse din meniuri.
 Barele de unelte: permit o accesare rapid a unor
comenzi folosite frecvent

Interfaa AutoCAD
 Linia de comand (command line):
Metoda tradiional de introducere a comenzilor n AutoCAD, prin
tiprirea acestora la promptul "Command:"
Toate comenzile pot fi introduse din linia de comand. Chiar i
atunci cnd sunt introduse din meniu sau bare de unelte,
comenzile sunt reflectate n linia de comand.
Interaciunea dintre utilizator i program are loc prin mesajele din
linia de comand.
Unele comenzi au nevoie de diverse opiuni (parametri) pe care
utilizatorul trebuie s le introduc n linia de comand.
Linia de comand conine n mod implicit trei rnduri. Apsnd
tasta F2 se deschide o fereastr text care conine o istorie a
comenzilor introduse n sesiunea curent de lucru.

 Bara de stare:
Afieaz coordonatele curente n colul stnga-jos a ecranului
Conine cteva butoane care afieaz/modific cteva setri ale
desenului

Introducerea comenzilor
 Din linia de comand
Forma lung: metoda tradiional,
prin tastarea comenzii (ex. line)
forma scurt [alias]: poate fi foarte
eficient (ex. l)

 Meniu (ex. Draw>Line)


Ruleaz o comand (pentru o
comand simpl)
deschide o caset de dialog (atunci
cnd comanda este urmat de )
deschide un submeniu (atunci cnd
comanda este urmat de
)

 Bara de unelte

Linia de comand
 Comanda se introduce n linia de comand, urmat de
ENTER sau
SPACE, sau
click pe butonul dreapta de la mouse

 Comenzi de editare (DEL, backspace, sgei, etc.)


 Reutilizarea comenzilor: tastele sgei sus i jos
 vizualizarea istoriei comenzilor : tasta F2 (deschide
fereastra de text)
 Urmrii permanent linia de comand!
 Formatul opiunilor unei comenzi:
Current instruction or [options] <current value>:
Pentru a selecta o opiune, tastai literele evideniate
Pentru a accepta valoarea curent (implicit), apsai enter

Tehnici de introducere a comenzilor


 Repetarea unei comenzi:
apsai enter (sau spaiu, sau click pe butonul dreapta de la
mouse) penru a repeta ultima comand
tastai MULTIPLE nainte de introducerea unei comenzi pentru
repetarea de cteva ori a acelei comenzi

 Anularea unei comenzi: tasta ESC


 Undo i Redo: AutoCAD nregistreaz toate comenzile
care au fost executate n sesiunea curent de lucru, iar
acestea pot fi derulate

Comenzile UNDO si REDO


 Comanda U: deruleaz ultima comand introdus
 Comanda UNDO - opiuni:
Auto/Control/BEgin/End/Mark/Back/<Number>
Number: numrul de operaii pe care s le deruleze
Auto (On/Off): Se aplic comenzilor din meniuri care execut o
serie de comenzi. On - este derulat ntreaga serie de comenzi.
Off - derularea comenzilor este efectuat pas cu pas.
Control (All/None/One): All - o funcionalitate total a comenzii
UNDO; None - dezactiveaz comanda UNDO; One - poate fi
derulat doar un singur pas
Begin i End: grupeaz o secven de comenzi ntr-un grup care
poate fi derulat n bloc
Mark i Back: marcheaz o stare a desenului, care pn la care se
poate derula mai trziu folosind opiunea Back

 REDO: "deruleaz derularea"

reface efectul unei comenzi U sau UNDO precedente


poate fi folosit o singur dat
trebuie s urmeze imediat unei comenzi U sau UNDO

Comenzi transparente
 Comenzi introduse n cadrul unei alte comenzi active
 Exemplu: zoom (permite schimbarea modului de
vizualizare a desenului, poate fi folosit transparent n
timp ce este activ o comand de desenare)
 Comenzile care suport transparena i sunt accesate din
barele de unelte sunt transparente automat
 Pentru ca o comand s fie apelat n mod transparent n
linia de comand, aceasta trebuie s fie precedat de un
apostrof
Command: l
LINE From point:
To point: 'zoom
>>All/Center/Dynamic/Extents/Previous/Scale(X/XP)/Window/<Realti
me>:
>>Press Esc or Enter to exit, or right-click to activate pop-up
menu.
Resuming LINE command.

Ajutorul
 Gsirea informaiei despre o comand specific se
poate obine apsnd tasta F1 atunci cnd este activ
comanda respectiv

Ajutorul
 Ajutor General: tasta F1 sau Help>Help (din meniu)
Contents: ajutor organizat dup subiect
User's Guide: ajutor de tip "cum s..."
Command Reference: informaii asupra comenzilor i a variabilelor
de sistem

Index: o list alfabetic a subiectelor


Search: cutarea unor cuvinte-cheie n tot materialul disponibil
Favorites: folosit pentru colectarea unor subiecte favorite
Ask Me: formularea unei ntrebri n limbaj normal

 Organizarea unui subiect:

Concepts: o descriere de ansamblu a problemei


Procedures: descrierea procedurilor de realizare a problemei
Reference: comenzi legate de subiect

Coordonate
 Coordonatele sunt folosite pentru specificare punctelor n
AutoCAD, i sunt specificate fa de sistemul de coordonate
utilizator
 Sistemul de coordonate global - World Coordinate System
(WCS) este sistemul de coordonate implicit al AutoCAD (un
sistem Cartezian XYZ fix)
 Sistemul de coordonate utilizator - User Coordinate System
(UCS) este un sistem Cartezian XYZ modificat de utilizator
 Pentru desene n plan, trebuie specificate doar coordonatele X
i Y
 Unitile desen: AutoCAD nu are uniti de msur - este la
latitudinea utilizatorului s decid dac valorile pe care le
folosete sunt mm sau km sau oli.
 AutoCAD desenul se realizeaz de obicei la scara 1:1 (o cldire
de 12x10m va fi desenat cu dimensiunile de 12x10m)
 Coordonatele pot fi introduse folosind mouse-ul, fie de la
tastatur

Introducerea de la tastatur a coordonatelor


Carteziene
 Coordonate absolute (x,y): sunt
specificate n raport cu UCS-ul curent.
exemplu: pentru a desena o linie de la
punctul (-2,1) la (3,4):
Command: line
From point: 2,1
To point: 3,4
 Coordonate relative (@x,y): sunt
specificate fa de ultimul punct introdus.
exemplu: pentru a desena o linie de la
punctul (-2,1) la un punct care se afl
la 5 uniti n direcia pozitiv a axei X:
Command: line
From point: -2,1
To point: @5,0

Introducerea de la tastatur a coordonatelor polare


 Setrile implicite pentru msurarea
unghiurilor:
Unghiurile sunt exprimate n grade
Zero grade corespund axei pozitive X
Unghiurile sunt pozitive n sens anti-orar

 Coordonate absolute (distance<angle):


specificate fa de originea UCS.
exemplu:
Command: line
From point: 0,0
To point: 4<120
To point: 5<30
 Coordonate relative (@distance<angle):
specificate fa de ultimul punct introdus.
exemplu:
To point: @3<45

Introducerea distanelor i modul ORTHO


 Introducerea direct a distanelor: dup specificarea unui
punct, se indic direcia dorit cu mouse-ul i se
specific prin tastare distana dorit. Deosebit de util
mpreun cu modul ortogonal i cu urmrirea polar
(polar tracking).
 Modul ortogonal
Restricioneaz micarea cursorului la direciile orizontal i
vertical (n raport cu UCS-ul curent)
Activate dezactivate prin:

tasta F8
butonul ORTHO din bara de stare
comanda ORTHO

 Modul ORTHO i urmrirea polar nu pot fi active n


acelai timp

Urmrirea polar (polar tracking)


 Ajut la executarea desenelor la alte unghiuri dect cele
ortogonale
 Direcia de aliniere i o
etichet (tooltip) sunt afiate
atunci cnd cursorul se apropie de unghiurile specificate
 Pentru setarea unghiurilor:
Tools>Drafting Settings
click dreapta de la
mouse pe butonul POLAR
din bara de stare i selectarea
"Settings"

 Incrementele unghiurilor pot


fi de 0, 60, 45, 30, 22.5, 18, 15,
10, sau 5 grade, sau la intervale
specificate de utilizator
 Pentru activare/dezactivare se
folosete tasta F10 sau butonul POLAR din bara de stare

Afiarea coordonatelor
 Afiarea coordonatelor ajut la editarea desenelor, pentru
a cunoate coordonatele curente, sau distana i direcia
n care se mic cursorul
 Trei stri ale afiajului coordonatelor:
absolute dinamice: coordonatele X,Y,Z sunt actualizate cu
micarea mouse-ului.
absolute statice: coordonatele X,Y,Z sunt actualizate numai la
specificarea unui punct.
relative dinamice: actualizeaz distana relativ (distan<unghi,Z)
cu micarea cursorului. Aceast opiune este disponibil numai la
desenarea obiectelor care necesit specificare a mai mult de un
punct.

 Schimbarea modului de afiare a coordonatelor:


tasta F6
click pe suprafaa de afiare a coordonatelor n bara de stare
combinaia de taste ctrl+D

Snap
 Ajut la specificarea precis a punctelor cu ajutorul
mouse-ului
 SNAP: restricioneaz micarea cursorului la intervale
specificate de-a lungul axelor X i Y
Setarea:
Tools>Drafting settings
sau click pe dreapta de la
mouse pe butonul SNAP
din bara de stare i selectarea
"Settings"

Activarea/dezactivarea:

tata F9
butonul SNAP din bara de stare
Tools>Drafting settings

 Punctele de SNAP sunt invizibile


 Este posibil rotirea
reelei de snap cu un unghi, precum i schimbarea originii

Caroiajul (GRID)
 GRID: un caroiaj rectangular de puncte care umple u
suprafa specificat prin limitele desenului. Caroiajul
ajut la alinierea obiectelor i la vizualizarea distanelor
dintre acestea.
Setarea:
Tools>Drafting settings
sau click pe dreapta de la
mouse pe butonul GRID
din bara de stare i selectarea
"Settings"

Activarea/dezactivarea:
tata F7
butonul GRID din bara de stare
Tools>Drafting settings

 Pasul caroiajului nu este


necesar identic cu
cel al reelei SNAP

Limitele
 Limitele desenului sunt puncte n plan, specificate fa de
sistemul global de coordonate, care reprezint colurile
stnga-jos i dreapta-sus a suprafeei de lucru.
 Dac verificarea limitelor este activat (opiunea On),
introducerea coordonatelor este restricionat la
suprafaa dreptunghiular a limitelor.
 Limitele determin i suprafaa desenului pe care este
afiat caroiajul.
 Opiuni:
Specify lower left corner or [ON/OFF]
<0.0000,0.0000>
specificarea colurilor (stnga-jos i dreapta-sus)
ON: AutoCAD nu permite introducerea coordonatelor
n afara limitelor desenului
OFF: dezactiveaz verificarea limitelor desenului

Tipul i stilul de snap


 Snap/Grid isometric
faciliteaz crearea vederilor isometrice
doar simuleaz un desen spaial, acesta fiind de fapt plan
dup setare, sunt disponibile trei planuri:
Left (stnga). Aliniaz snap-ul i caroiajul dup axe la 90 i 150.
Top (sus). Aliniaz snap-ul i caroiajul dup axe la 30 i 150.
Right (dreapta). Aliniaz snap-ul i caroiajul dup axe la 30 i 90.

schimbarea planului isometric:


tasta F5 sau
CTRL+E

 PolarSnap restricioneaz micarea


cursorului la intervale (distane) polare
specificate de utilizator.
Odat cu micare cursorului, o etichet (tooltip) indic cel mai
apropiat increment PolarSnap.
Pentru a restriciona introducerea distanelor polare, trebuie s fie
active att urmrirea polar, ct i modul snap.

Create a new drawing using a template


 Command:
menu: File>New
keyboard: NEW

 NEW creates a new


drawing
Behaviour depends on
the startup settings at Tools>Options>>System>>Startup:
Show the Startup Dialog Box: NEW displays the Create New Drawing
dialog box. To use a template select the "Use a template tab".
Do Not Show the Startup Dialog Box: NEW displays the Select
Template dialog box (a standard file selection dialog box).

Creating, opening and saving drawings


 AutoCAD uses common procedures in order to create,
open, close, and save its drawings

To create a new drawing: File>New (Ctrl+N)


To open an existing drawing: File>Open (Ctrl+O)
To close a drawing: File>Close (Ctrl+F4)
To save a drawing: File>Save (Ctrl+S)
To save a drawing with a different name: File>Save As
(Ctrl+Shift+S)

 A template is a special file containing standard settings


and objects, used as a basis for new drawings
 acad.dwt - a simple template containing default imperial
settings - loaded when the "imperial settings" are used
on the "Start from scratch" tab
 acadiso.dwt - a simple template containing default metric
settings - loaded when the "metric settings" are used on
the "Start from scratch" tab

Create a new drawing using default template


 Command:
keyboard: QNEW
toolbar:

 QNEW starts a new drawing from the current default


drawing template.
When the default template is NOT specified, behaviour depends
on the startup settings at Tools>Options>>System>>Startup:
Show the Startup Dialog Box: displays the Create New Drawing
dialog box.
Do Not Show the Startup Dialog Box: starts the new drawing using
the default drawing template file (if the template is specified in
Tools>Options>>Files) or displays the Select Template dialog box (if
template = none)

 The default template for the QNEW command is specified


in Tools>Options>>Files>>Template Settings>>Default
Template File Name for QNEW